Problem
Zauważasz, że wiadomości wychodzące są wyświetlane z ostrzeżeniem, że mogą być spamem (nawet jeśli są legalne).
Środowisko
- Dostarczanie Gmaila
Rozwiązanie
Jeśli masz dostęp do konta w systemie dostawcy hostingu domeny i odpowiedniej konsoli DNS, wykonaj te czynności:
- Otwórz konto dostawcy hostingu domeny.
- Znajdź konsolę DNS lub sekcję, w której zarządzasz rekordami DNS.
- Usuń wszystkie rekordy SPF oprócz jednego i edytuj wartość pozostałego rekordu w taki sposób, aby obejmowała wszystkie potrzebne serwery (scal wszystkie rekordy SPF w jeden).
- Usuń wszystkie zduplikowane rekordy DKIM powiązane z Google.
- Zapisz zmiany.
Przyczyna
Skonfigurowano wiele rekordów SPF i DKIM, co spowodowało nieprawidłowe uwierzytelnianie wiadomości.