Wiadomości wychodzące zawierają nieprawidłowe ostrzeżenie o spamie

Problem

Zauważasz, że wiadomości wychodzące są wyświetlane z ostrzeżeniem, że mogą być spamem (nawet jeśli są legalne).

Środowisko

  • Dostarczanie Gmaila

Rozwiązanie

Jeśli masz dostęp do konta w systemie dostawcy hostingu domeny i odpowiedniej konsoli DNS, wykonaj te czynności:
  1. Otwórz konto dostawcy hostingu domeny.
  2. Znajdź konsolę DNS lub sekcję, w której zarządzasz rekordami DNS.
  3. Usuń wszystkie rekordy SPF oprócz jednego i edytuj wartość pozostałego rekordu w taki sposób, aby obejmowała wszystkie potrzebne serwery (scal wszystkie rekordy SPF w jeden).
  4. Usuń wszystkie zduplikowane rekordy DKIM powiązane z Google.
  5. Zapisz zmiany.
Uwaga: w zależności od dostawcy hostingu domeny prawidłowe rozpowszechnienie zmian może potrwać do 72 godzin.
 

Przyczyna

Skonfigurowano wiele rekordów SPF i DKIM, co spowodowało nieprawidłowe uwierzytelnianie wiadomości.