Problem
Phishing email was not properly detected and reached your inbox.
Environment
- Admin console
Solution
Enable Safety settings by following the steps described below:
- Log in to the Admin console.
- Navigate to Apps > Google Workspace > Gmail > Safety.
- Scroll down and click Spoofing and authentication.
- Click the checkbox in the available options (Protect against inbound emails spoofing your domain).
- Choose the action Move emails to spam or Quarantine.
- Save changes.
Cause
The option selected in the Safety settings were set to Leave email in inbox and show warning.