Problem
When trying to change a user's email address, the change appears to be successful, and it says Primary email updated, however, the changes are not applied to the user's email address and the original primary email address remains.
Environment
- Admin console
Solution
Note: Email aliases should not exceed 30 in total.
- In the Google Admin console.
- Navigate to Main Menu > Directory > Users.
- Click the user's name to open the user settings page.
- Under the user's name, click Add Alternate Emails.
- Next to the email alias shown on the right side, click Remove X next to the one you want to delete.
- Click Save.
Cause
This is an expected behavior whenever the email alias limit of 30 has been reached for the user. When a user's primary email address is updated, the old one becomes an email alias automatically, however, if there is no more room for email aliases, the change in the email alias is not applied.