Some emails in Gmail labels did not transfered after a data migration

Problem

After a data migration process you noticed that some of your labels were not migrated or emails are missing.

Environment

  • Gmail web interface
  • Admin console
  • Data migration feature

Solution

Check in your source account if labels are shown on IMAP:
  1. Access mail.google.com and enter the source account.
  2. Click on the Gear at the upper right and select See all settings.
  3. Go to the Labels tab, next to each label, make sure the  Show in IMAP option is checked.
  4. Save the changes.
  5. Restart the migration in your Admin console.
If you don't see the Show in IMAP next to the label you will need to enable the IMAP access for your account by following the steps described below:
  1. Go to Gmail settings > Forwarding POP/IMAP. 
  2. Enable the IMAP access option.

 

Cause

Labels are not being shown for IMAP under the source account Gmail settings.