SPF schlägt aufgrund von 10 Domainprüfungen fehl

Problem

Der SPF-Eintrag ist korrekt eingestellt, aber SPF schlägt aufgrund zu vieler Domain-Lookups fehl (das Limit ist 10). Dies wird in RFC 7208, Abschnitt 4.6.4, angegeben. DNS-Lookup-Limits: Wenn ein Kunde mehr als zehn Abonnenten erreicht, schlägt das SPF-Ergebnis immer fehl und die E-Mail wird in den SPAM-Ordner verschoben.

Umgebung

  • DNS-TXT-Eintrag für SPF-Authentifizierung

Lösung

  1. Prüfen Sie verschachtelte Lookups. Diese werden auf das Limit von 10 angerechnet. Wenn Ihr SPF-Eintrag eine Domain enthält und diese Domain weitere Domains in ihrem SPF-Eintrag enthält, werden diese Domains auf das Limit für SPF-Einträge angerechnet. Dazu können Sie die Google Admin Toolbox verwenden > Tool zum Prüfen der MX-Datensätze.
  2. Der Kunde muss den TXT-Eintrag für SPF bearbeiten und alle Einschließen-Mechanismen für Drittanbieter entfernen, die keine E-Mails mehr für Ihre Domain senden.

Ursache

Im RFC-Spezifikationsdokument RFC7208 ist festgelegt, dass die Anzahl der Mechanismen und Modifikatoren, die DNS-Lookups ausführen, pro SPF-Prüfung nicht mehr als 10 betragen darf. Bei Überschreitung des Limits kann der Fehler zurückgegeben werden.

Permerror SPF permanent error too many DNS lookups.