Track email with message ID

Problem

Email found in the inbox of a user doesn't come up in Email Log Search. 

Environment

Admin console > Email Log Search > Searching an email with "Sender's" and "Recipient's" email address. 

 

Solution

1. The email is found in the inbox of one user, open the email. 

2. Click on the 3 dots button all the way to the right of the date and time, next to the star and reply buttons. 

3. Click on "Show original", a new tab will be opened, that's the message header. 

4. Copy the message ID, the green colored string of characters at the top. 
5. Go to the Admin console homepage (at admin.google.com), and on the left side menu, click on "Reporting">"Email log search". 

6. Specify the date in which the email was received and paste the message ID in the respective field, and click on "Search". 

 

Cause

Sometimes the email may not be found by searching with the sender's email address as a search criteria since some automated emails might show an email address to the end recipient's inbox while the Email Log Search is provided with a different email address, causing the email not to be easily found.