Unable to access Google Workspace core services

Problem

A newly created user is unable to access core services like Gmail, whenever there is an attempt to do so an error message comes up referring the user to the admin.

Environment

  • Gmail
  • Admin console

Solution

  1. In your Google Admin console.
  2. In the left-hand panel, go to Directory > Users.
  3. Next to each user's name where you want to assign or remove a license, check the box.
  4. At the top, click More Assign Licenses or Remove Licenses.
  5. Click the service > Assign or Remove.
or
  1. In your Google Admin console.
  2. In the left-hand panel, go to Directory > Users.
  3. Click the name of the user you want to manage.
  4. Scroll down and click the user's License section.
  5. Click any service to display the on/off switches in the Status column.
  6. Next to a service, in the Status column, click the switch to assign or remove a license.
  7. Click Save.

Cause

If a Google Workspace license is not assigned, the user is unable to access our core services.