Problem
When you try to locate a device on Find my device https://www.google.com/android/find you get a different site instead.
Environment
-Account with advanced mobile management.
-All browsers/OS affected.
-All browsers/OS affected.
Solution
- Go to the Admin console and from the menu on the left select Devices > Mobile and endpoints > Settings > Android Settings.
- Click on General.
- Click on User device wipe and make sure it is set to allow it.
Note: This change only takes effect if advanced management is ON.
Cause
This happens because of the User device wipe policy.