Unable to access Workspace account

Problem

Unable to access Google Workspace account on iOS and is getting an Unregistered message on the Google Device policy app.

Environment

  • iOS mobile devices

Solution

  1. Download a certificate signing request.
    1. Log in to the Admin console.
    2. Navigate to MenuDevices > Mobile & endpointsSettingsiOS.
    3. Click Apple certificates > Set Up New Certificate.
    4. Under Certification Request, click Get CSR.
    5. Save the certificate signing request (.csr) file to a convenient location where you can access it later.
      • Download this file only once. 
  2. Get a signed certificate from Apple.
    1. From your Admin console, click Apple Push Certificates Portal and sign in to the portal with your Apple ID and password.
    2. Click Create a Certificate and accept the terms of use.
    3. Click Choose File and select the certificate signing request (.csr) file you saved earlier.
    4. To submit the request file, click Upload.
    5. Apple accepts the request and displays a confirmation page with your service type, vendor domain, and the expiration date for this certificate.
    6. Click Download and save the signed certificate (.pem) file. Download this file only once.
    7. Go back to your Admin console tab or window. 
  3. Upload your signed certificate.
    1. Under Enter Business Apple ID, enter the Apple ID you used to create the certificate. Your ID is automatically saved to remind you when you renew the certificate.
    2. Click Upload Certificate and select the certificate (.pem) file you saved from the Apple Confirmation page. 
    3. Click Save & Continue.

Cause

Apple push certificate is not configured.