Unable to archive email since the operation is blocked by your SSO provider

Problem

You receive a 18017 error during the initializing phase of the migration.

Environment

  • Admin Console

Solution

  1. Check if IMAP and Less Secure Apps are enabled in the source account.
  2. Check if more than 24 hours have passed since the previous step was enabled.
  3. Make sure the user does not have 2-Step Verification. If so, use the App Password instead.
  4. Exit the migration and set it up again.
  5. Change the migration source from Google Workspace to Gmail.

Cause

IMAP or Less Secure Apps is not allowing the migration tool to scan the account to index the messages.