Unable to create or add items in an external folder

Problem

Users with a Content manager role are unable to create or add new items to a shared folder owned by an external organization.

Environment

  • Google Drive

Solution

  1. Log in to the Admin console.
  2. Go to Menu > Apps > Google Workspace > Drive and Docs.
  3. Click Sharing settings > Sharing options.
  4. To apply the setting to everyone, leave the top organizational unit selected. Otherwise, select a child organizational unit or a configuration group.
  5. To turn on external sharing:
    1. In the Sharing outside of your organization section, click On and choose sharing options.
    2. To warn users when they try to share externally, check the Warn when files owned by users or shared drives in your organization are shared outside of your organization box.
    3. To allow users to share content with people who don't use Google Accounts, check the Allow users or shared drives in your organization to share items with people outside your organization who aren't using a Google account box.
      • Note: To edit or comment on files, users must sign in to a Google Account (or a visitor account if you have visitor sharing turned on)
    4. To allow link sharing (when anyone with the link can access the file), check When sharing outside of your organization is allowed, users in your organization can make files and published web content visible to anyone with the link.
  6. Click Save. If you configured an organizational unit or group, you might be able to either Inherit or Override a parent organizational unit, or Unset a group.

Cause

External sharing controls whether users can create content in folders owned by an external or not so having it off prohibits item creation.