Unable to delete user due to Vault Policy

Problem

You received an error saying there's a Google Vault Policy with data in hold when trying to delete a user. 

Environment

  • Admin console
  • Google Vault

Solution

A second service may be added in the Admin console in order to manage licensing:
  1. Go to the Admin console.
  2. Go to Billing and then Subscriptions and then Add or upgrade a subscription.
  3. Add Cloud Identity Free.
  4. Then check that Auto licensing is off by going to the main subscriptions page, click your Google Workspace edition and then License settings and turn Auto Licensing to OFF.
  5. Go to Users and click the user's name you will be deleting.
  6. Click Licenses and turn off the one for your Google Workspace editions.
  7. Save the changes.
  8. Delete the user.

Cause

Users cannot be deleted if a Google Vault Policy is affecting them to prevent accidental data loss.