Unable to deliver internal messages

Problem

Internal messages cannot be delivered due to a Local Mail exchanger delivery issue.

Environment

  • Gmail

Solution

  1. Log in to cPanel.
  2. Click the Email Routing icon on the Email section.
  3. Select your domain name from the dropdown menu.
  4. Set the correct email route
  5. Remote Mail Exchanger, use this to point your emails to a different email service or server.
  6. Click the Change button and test your email.

Cause

Messages are doing a local MX lookup