Unable to login to Google Drive using CleverTouch Interactive Screen

Problem

Login to Google Drive using CleverTouch Interactive Screen (third party client) fails due to the following error message: Error 400: admin_policy_enforced.

Environment

  • Non Google Device, login through third party client

Solution

The error message when trying to sign in must show a third party client ID, this ID needs to be added in the Admin console Allow list:
  1. Log in to the Admin console.
  2. Open Security > Access and data control > API controls.
  3. Select Manage third party apps access.
  4. Click Add app and then OAuth App Name Or Client ID.
  5. Enter the client ID and click Search.
    • Make sure there is no spaces at the end or the beginning.
  6. Select the app that you found in the result.
  7. Checkmark the box and then click Select again.
  8. Make sure to select Trusted: Can access all Google Services and then select Configure
Once these steps are followed, you can try again immediately, however it make take up to 24 hours for the changes to propagate.

Cause

The third party client need to be allowed in Admin console.