Unable to open a file in Drive for desktop

Problem

When trying to open a document in Drive for desktop you get the following error message: Access denied.
 

Environment

  • Drive

Solution

  1. Open the file location.
  2. Move it to a folder above the location of the one where the affected file is.
Workaround:
  • An alternate solution is to rename the folders to shorter names, to reduce the number of characters.
  • An unsupported solution is to change the registry of windows to allow longer paths, but this needs to be done with Microsoft support directly. 

Cause

The length of the path (260 characters) where the file is exceeds the allowed on Windows