Unable to push policies to Chrome devices

Problem

You notice that some of the policies are not fetched by the Chromebooks even though they seem to be synced.

Environment

  • Chromebook
  • ChromeOS

Solution

To fix the issue, you need to make sure that the devices are in the correct organization. Or in rare cases, policy updates get stuck, moving devices between OUs may help to trigger policy updates.

  1. In your Admin console.
  2. Go to Devices > Chrome > Devices.
  3. On the left, click the organizational unit the device is in.
  4. Check the box next to the device you want to move.
  5. At the top, click Move.
  6. Choose the organization that you want to move the device to.
  7. Click Move.

Workaround:
If you observe policy sync errors in Policies, you can turn off and on sync as described in Move a ChromeOS device to an organizational unit .

Cause

Though the device is synced since it is fetching the policies from the current org unit it was under. But the affected device is not on the correct org unit where the correct policies are causing it not to get the preferred settings.