Unable to receive emails

Problem

Customer is unable to receive emails due to MX records.

Environment

  • Google Workspace
  • Gmail

Solution

  1. Open your domain host's website.
  2. Go to the Domain Management page.
  3. Add new MX records.
  4. Wait 24-48 hours for the records to propagate.

Cause

The customer changed the domain's NameServer recently, therefore the MX records need to be configured again.