Unable to receive emails due to expired domain registration

Problem

You are unable to receive emails due to expired domain.

Environment

  • Google Workspace setup

Solution

Tip: If you're no longer receiving emails all of a sudden and you don't recall any changes. It's most likely that your domain has expired. And once your domain has expired, your domain will be down and your emails will be affected.

What to do:

  1. Contact your domain host.
  2. Renew your domain.
  3. Check with your domain host and make sure you have the Google Workspace MX records.
  4. Review Google Workspace MX record values.

Note: There's a propagation period for the changes to take full effect which depends on your domain host. In general, it propagates within 24-48 hours, but sometimes it can be just a few minutes or it could take up to 72 hours. 

Cause

Emails affected due to expired domain.