Problem
How can you validate your mail exchange (MX) Records are correct when you are not receiving emails?
Environment
- Gmail configured for company's email messages
Solution
Use the Dig tool's MX tab to validate currently configured MX Records
- Navigate to the Dig Tool.
- Select NS.
- In the name field, put in your domain name and press enter, for example: example.com
- Do not put www. prior to your domain name.
- If you receive Record not found! Please ensure that you have spelt your domain correctly.
- If you receive an output, proceed to the next step, otherwise, please contact support for assistance.
-
Select MX. An output of your MX Records will show. Your MX Records must look like the following (in any order):
- TTL: (a value of time, this can be ignored)
- EXCHANGE: (see below)
- PREFERENCE: (see below)
Exchange Preference aspx.l.google.com 1 alt1.aspmx.l.google.com 5 alt2.aspmx.l.google.com 5 alt3.aspmx.l.google.com 10 alt4.aspmx.l.google.com 10
- If you do not see this information returned, or other exchange listed with different preference, you must update your domain's MX records to match these. For instructions on how to do this, please see the following help article for common domain host or reach out to your domain host for more assistance.
- Please wait up to 72 Hours for these changes to propagate
Cause
MX Records are required to be set or updated to the information shared above in order for your company's mail server to know where to deliver it's email messages.