Problem
You create a new user account, inside a new domain, sent a test email to newly created user, but a bounce back message is received:
Your message wasn't delivered because the address couldn't be found, or is unable to receive mail
Environment
- Gmail Delivery
- Admin Console
Solution
Confirm the domain's MX Records are configured using the Dig tool. See the following article for which MX Records need to be seen with this tool.
Cause
Google MX records are missing on the domain which are capable of receiving emails on the domain.