Unable to restore a recently deleted user

Problem

You are unable to restore a recently deleted user because a new user was created with the same email address.

Environment

  • Admin console

Solution

Delete the new user

  1. Go to the Admin console.
  2. Click Users.
  3. Select the checkbox of the user and click More options from the top.
  4. Select Delete selected users.
  5. Proceed to delete the user.

Restore the old user

  1. Go to the Admin console.
  2. Click Users.
  3. Click Add a filter from the top and select Recently deleted users.
  4. You will see 2 users with the same email address. Click Recover on the user that has least remaining days to get retrieved.

Cause

Users cannot  get recovered if their email addresses (primary or email aliases) are in use by other users.