Problem
You are unable to recover a recently deleted user attached to other account
Environment
- Google Workspace.
- Web UI.
- Visitor account.
Solution
To Resolve:
- Go to admin.google.com then under users > add new user and create a user with the user name user@Domain
- Change that user name as test.user@Domain.
- From users > click the user's name
- Click on update user, you will be able to change the email address there.
- Delete the email alias automatically created.
- From the user profile > user information > click the email address click the "X" > save.
- Restore the account User@domain.
- From the Admin console, under users > add a filter > recently deleted >
- Hover over the user and click on recover.
- Delete the user test.user@domain
Cause
There is a visitor account created with the same email address that the admin is trying to recover, this can not be found from the admin side.