Unable to see recent device events

Problem

You notice that recent device events are not showing in the Admin console.

Environment

  • ChromeOS
  • Device list

Solution

  1. Log in to the Admin console.
  2. Navigate to Devices > Chrome > Settings > Device.
  3. Enable Report device hardware information and Report device telemetry.
  4. Save the changes.
  5. Go to Devices > Chrome > Settings > Users and browsers.
  6. Enable Managed browser reporting and Event reporting.
  7. Save the changes.
  8. Allow 24 hours for the events to start showing.

Cause

Device reporting policies must be enabled.