Unable to set up 2-Step Verification with a different phone number

Problem

After turning 2-Step Verification off for a user and changing the recovery phone number, when trying to set up 2-Step Verification again you are prompted to verify your identity through the old phone number.

Environment

  • Admin console 
  • Security 
  • Login challenge
  • 2-Step Verification 

Solution

  1. Log in to the Admin console.
  2. Go to MenuDirectory > Users.
  3. Click the row for the user account to display the user information page.
  4. Click Security.
  5. Scroll down to find the Login challenge section, and click on it.
  6. Click Turn Off For 10 Minutes.

Cause

Login challenges are commonly presented when performing major security changes in a Google account.