Problem
When trying to launch the Password Sync application, you receive the following error message:
Please check that the specified admin user exists in G Suite and is not suspended or disabled.
Environment
- Password Sync Application
Solution
You must create the service account in Google Cloud by following these steps:
- Sign in as a super administrator.
- In a browser window, open Cloud Shell.
- In the editor, enter the script described in Password Sync to create an authorized service account for Password Sync.
- Complete the steps in the Cloud Shell window.
- Click Download to download the JSON file that contains the service account's client ID to your computer.
Cause
This occurs due to the service account has not been created, it is suspended, or it has been deleted from Google Cloud.