Unable to sync passwords with Password Sync application

Problem

When trying to launch the Password Sync application, you receive the following error message:
Please check that the specified admin user exists in G Suite and is not suspended or disabled.

Environment

  • Password Sync Application

Solution

You must create the service account in Google Cloud by following these steps:

  1. Sign in as a super administrator.
  2. In a browser window, open Cloud Shell.
  3. In the editor, enter the script described in Password Sync to create an authorized service account for Password Sync.
  4. Complete the steps in the Cloud Shell window.
  5. Click Download to download the JSON file that contains the service account's client ID to your computer.
Note: Please note that this script is not supported by Google Workspace support. If you are experiencing issues, you should manually create the account by following the steps listed in Create a service account.

Cause

This occurs due to the service account has not been created, it is suspended, or it has been deleted from Google Cloud.