Problem
When trying to transfer Google Drive files from a Google Workspace account to another, using the transfer files tool on the Admin console, you get an error message stating that you can not transfer the files due to a legal hold.
Environment
- Admin console web UI
- Transfer files tool
Solution
Step 1 Add a free service. If you have a free service such as cloud Identity free or Android Management, continue to:
Step 2 Access Google Cloud Identity
Step 3 Create a new organizational unit
Step 2 Access Google Cloud Identity
- In your Google Admin console.
- Go under Billing > Get more services > Cloud Identity.
- Click on start free trial under Cloud Identity free and follow the on-screen instructions to place the order.
- Note: this is a free subscription, no payment required.
- Go to Menu > Directory > Organizational units.
- Hover over the organization you want to modify and click Create new organizational unit.
Step 4 Turn off Google Workspace auto licensing
- From the left side panel of the Admin console.
- Go under Billing > License settings.
- On the left side choose the organizational unit you want to affect and click to turn off Google Workspace auto licensing for that organizational unit.
Step 5 Remove Google Workspace license from the user.
- Move the user to that organizational unit.
- Go under users in the list of users look for the user you want to delete.
- Check the box next to the user's name then on top click on more options and select the remove license option.
- In your Google Admin console.
- Go to Menu > Apps > Google Workspace > Drive and Docs.
- Click Transfer ownership.
- For From user, enter the current owner's email address and select the user from the results.
- For To user enter the new owner's email address and select the user from the results.
- Click Transfer Files.
Cause
There is a Google Vault hold that is not allowing to transfer file ownership.