Unable to use Drive for desktop on a MacOS device

Problem

Unable able to startup Drive for desktop when system starts up.

Environment

  • Drive for desktop
  • MacOS

Solution

  1. Add the Drive for desktop app to Login Items.
  2. Select the Apple menu  > System Preferences > General > Login Items.
  3. If you see any Google Drive application there, first remove it by highlighting it and clicking on the minus icon to remove it and then click on the plus icon and then on the left menu click on applications and the search for Google Drive app and select that one and click on Open.

Cause

Google Drive application was not automatically added to the Login Items settings on the Mac OS system.