Unable to use Smart Switch on Android Devices

Problem

Unable to use Smart Switch due to an error: Device Policy Alert.

Environment

  • Android
  • iOS

Solution

  1. Use a personal account to transfer files and all data from your old phone to the new one.
  2. After all needed data was transferred, add your Google Workspace account on your phone.

Cause

Documentation from Samsung: Smart Switch no longer works on Fully Managed with Work Profile devices as it was not designed for enterprise environments. While Smart Switch can be installed and may have worked previously on a device in this configuration, the app was not officially supported in this type of environment and it is now disabled by default starting with version 3.7.05.8. The warning message will now appear and prevent the app from launching.