Upgrade license consumed unexpectedly on ChromeOS Flex

Problem

The devices you updated from CloudReady to ChromeOS Flex are powerwashed and a new upgrade license is consumed in the Admin console.

Environment

  • Chrome OS Flex

Solution

  1. Deprovision the device that uses the MAC address as its default serial number.
  2. Log in to the Admin console.
  3. Navigate to Menu > Devices > ChromeDevices.
  4. At the top, use the filter to select the current status of the device that you want to deprovision.
  5. To apply the setting to everyone, leave the top organizational unit selected. Otherwise, select a child organizational unit.
  6. Check the box next to the device that you want to deprovision.
    • Note: If you are deprovisioning multiple devices for different reasons, deprovision them in groups, depending on the reason.
  7. At the top, click Deprovision selected devices.
  8. Specify whether devices automatically factory reset. Choose an option:
    • Yes, factory reset to remove all data including user profiles, device policies, and enrollment data.
    • No, keep existing data and user profiles.
  9. Check the box to confirm that you understand the actions to re-enroll a device.
  10. Select your deprovisioning reason. 
    • Note: If there are annual upgrades on the account, or if all devices selected are Chrome Enterprise devices, you do not have to select any deprovisioning reason. For more details, see About Chrome Enterprise devices.
  11. Click Deprovision.
    • Note: Deprovisioned devices remain in their organizational unit, even though you no longer manage them.

Cause

When powerwashed after an update from CloudReady, the device's serial information also changes in the Admin console. A device consumes a new upgrade if the system detects that it is not yet provisioned. Because of the difference in serial information, the device then enrolled as a new and separate item. CloudReady devices use the MAC as their default serial number. ChromeOS Flex uses the actual devices serial number.