Cómo ver los errores de aprovisionamiento automático

Cuando configures el aprovisionamiento automático para tus apps basadas en SAML, es posible que veas estos errores:

Sigue leyendo para obtener información sobre cómo depurar y resolver estos errores.

Errores de tiempo de configuración

Error de código de autorización

Verás este error cuando no se pueda intercambiar el código de autorización por un token de actualización. Esto puede suceder si el código de autorización es incorrecto o si esperas demasiado tiempo entre la autorización y el clic en Guardar cambios. Si vuelves a autorizar y guardas los cambios, se debería resolver este error.

Mensaje de error Resolución
No se pudo generar el token de autorización. Vuelve a intentar la autorización y guarda los cambios.

Error de página obsoleta

Los errores de página obsoleta se producen cuando no se actualizó la página del navegador del usuario y la configuración cambió fuera de esta sesión del navegador (ya sea desde una ventana diferente del navegador o por un usuario diferente). Estos son los errores asociados que podrías ver:

Mensaje de error Resolución
Tu página está obsoleta. Existe una configuración de aprovisionamiento. Actualiza la página para anular la configuración existente.
Tu página está obsoleta. No existe una configuración de aprovisionamiento. Actualiza la página para anular la configuración existente.
Tu página está obsoleta. No se puede activar una configuración de aprovisionamiento sin configurar. Actualiza la página para anular la configuración existente.
Tu página está obsoleta. No se puede borrar una configuración de aprovisionamiento sin configurar. Actualiza la página para anular la configuración existente.

Error de página transitorio

Estos errores son transitorios y deberían resolverse si actualizas la página o vuelves a intentar la acción después de un período.

Mensaje de error Resolución
No se pudo recuperar la configuración de aprovisionamiento Actualiza la página.
No se pudo recuperar la configuración previa del aprovisionamiento Actualiza la página.
No se pudo recuperar el estado del aprovisionamiento Actualiza la página.
No se pudo activar el aprovisionamiento Vuelve a intentar activar el aprovisionamiento.
Se produjo un error al borrar la configuración de aprovisionamiento Vuelve a intentar borrar la configuración.
No se pudo crear la configuración de aprovisionamiento Vuelve a crear la configuración de aprovisionamiento y guarda los cambios.
No se pudo actualizar la configuración de aprovisionamiento Vuelve a actualizar la configuración de aprovisionamiento y guarda los cambios.
No se pudieron recuperar los atributos personalizados Vuelve a intentar guardar los atributos personalizados.
No se pudo actualizar la asignación de atributos Vuelve a actualizar la asignación de atributos.
No se pudo actualizar la configuración de grupos para el aprovisionamiento automático Vuelve a actualizar la configuración de grupos.
No se pudo actualizar la configuración de anulación del aprovisionamiento Vuelve a actualizar la configuración de anulación del aprovisionamiento.
Se borró la configuración, pero no se pudo revocar el acceso del cliente de la API

Cuando borras la configuración, revocamos los permisos que permiten que tu aplicación acceda a tus datos de Google.

Si falla por algún motivo, revoca el acceso de forma manual. Para ello, accede a "Administrar acceso de cliente de API" en la sección Seguridad.

Si borraste la configuración y planeas volver a configurarla, no es necesario que realices ninguna acción.

Error al actualizar la configuración de aprovisionamiento Actualiza la página.
No se pudo realizar la autenticación Las credenciales de autenticación (p.ej., el token de portador) que se proporcionaron en la configuración son incorrectas. Ingresa las credenciales correctas.
La URL del extremo de SCIM proporcionada no es válida El extremo de destino proporcionado no es válido. Ingresa la URL correcta.
Se produjo un error al habilitar el aprovisionamiento Mueve el control deslizante de Aprovisionamiento automático a Activo.
Se produjo un error al borrar la configuración de aprovisionamiento
  1. Haz clic en Aprovisionamiento automático para abrir la configuración.
  2. En Borrar configuración, haz clic en Borrar.
No se pudieron recuperar los atributos de tu proveedor de servicios de destino
  1. Haz clic en Aprovisionamiento automático para abrir la configuración.
  2. En Asignación de atributos, haz clic en Editar.
  3. Edita las asignaciones del proveedor de servicios según sea necesario.
No se pudo recuperar el esquema de recursos de destino Verifica la URL del extremo proporcionada durante la configuración del aprovisionamiento automático y vuelve a intentar asignar los atributos de Cloud Directory a los atributos de la aplicación de destino.

Errores de tiempo de ejecución del aprovisionamiento automático

Las fallas de tiempo de ejecución del aprovisionamiento automático pueden ocurrir debido a problemas de acceso a la API, autorización o configuración.

Errores de servicios internos de Google

Código de error Descripción y resolución
17003
17006
17008

Descripción:

No se pudo autenticar con los servicios internos de Google.

Motivo:

Se revocaron los permisos de este ID de cliente de aprovisionamiento de usuarios:

910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

Resolución:

Asegúrate de que este ID tenga permisos para estos permisos:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

En la Consola del administrador, usa "Administrar acceso de cliente de API" en Seguridad > Configuración avanzada para verificar que el ID de cliente tenga estos permisos o para agregarlos a este ID de cliente.

17007

Descripción:

No se pudo otorgar acceso a las apps que admiten el aprovisionamiento automático con la delegación de autoridad de todo el dominio.

No se pudo otorgar autoridad de delegación de todo el dominio al servicio de aprovisionamiento automático. Esto es fundamental para que el servicio de aprovisionamiento automático pueda leer el directorio de Google.

Motivos:

Motivo 1: Se revocaron los permisos del ID de cliente de aprovisionamiento de usuarios.

Resoluciones:

En la Consola del administrador, usa "Administrar acceso de cliente de API" en Seguridad > Configuración avanzada para agregar el siguiente ID de cliente y los siguientes permisos:

ID de cliente:
910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

Permisos:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

Una resolución alternativa es borrar la app en cuestión y, luego, volver a agregarla.

Motivo 2: Errores inesperados del sistema

Resolución:

En la mayoría de los casos, este error se resolverá automáticamente. Sin embargo, si el problema persiste después de algunas horas, agrega el ID de cliente y los permisos, o borra la app y vuelve a agregarla, como se mencionó en el Motivo 1.

Errores de token de autenticación

Código de error Descripción y motivo Resolución
17010

No hay suficientes credenciales para realizar llamadas a tu extremo de SCIM.

Motivo: Se revocó el token de autenticación.

Vuelve a intentar la autorización. Para ello, haz clic en Aprovisionamiento automático para abrir la configuración y, luego, en Volver a autorizar.
17013

Se produjo un error al recuperar un token de acceso de tu proveedor de servicios.

Motivo: Se revocó el token de autenticación.

Si este error no se resuelve automáticamente después de un tiempo, vuelve a intentar la autorización. Para ello, haz clic en Aprovisionamiento automático para abrir la configuración y, luego, en Volver a autorizar.

Errores de token de acceso

Código de error Descripción y motivo Resolución
17002
17011

No se pudo generar un token de acceso.

Motivo: Algunos servicios internos de Google no están disponibles en este momento.

Este error debería resolverse automáticamente después de un tiempo.
17009 No se pudo generar el token de acceso a partir del token de actualización. Vuelve a intentar la autorización. Para ello, haz clic en Aprovisionamiento automático para abrir la configuración y, luego, en Volver a autorizar.

Errores generales

Código de error Descripción y motivo Resolución
1200x

Error interno

Este error debería resolverse automáticamente después de un tiempo.
25001 El backend o el servicio de Google no están disponibles en este momento. Vuelve a configurar el aprovisionamiento automático.
25002

El backend o el servicio de Google no están disponibles en este momento.

Motivo: La app no está instalada para el cliente.

Instala la aplicación y, luego, vuelve a configurar el aprovisionamiento automático.
25005 El backend o el servicio de Google no están disponibles en este momento. Este error debería resolverse automáticamente después de un tiempo.
25016 El backend o el servicio de Google no están disponibles en este momento. Vuelve a configurar el aprovisionamiento automático.
50001 Error interno Este error debería resolverse automáticamente después de un tiempo.
50003 Error interno Este error debería resolverse automáticamente después de un tiempo.
50005 Hay un grupo borrado en los filtros de grupos configurados. Quita el grupo borrado de la configuración del alcance del aprovisionamiento.
50006 Error interno Este error debería resolverse automáticamente después de un tiempo.

Errores a nivel de recursos

Si la sección Aprovisionamiento automático de la página de configuración de la app de SAML muestra Fallas, haz clic en Descargar lista. En el archivo descargado, se enumeran las acciones de creación, eliminación o actualización fallidas, y un código de error y una descripción para cada falla.

Estos errores solo afectan a los recursos especificados en el archivo.

Código de error Descripción del error Resolución
45003

Tu aplicación basada en SCIM no aceptó la solicitud de actualización, creación o eliminación de recursos. Consulta los detalles del error en el archivo de errores descargado.

Posibles motivos:

  1. Se superó el límite de licencias: Tienes licencias para crear solo 5 usuarios en tu aplicación basada en SCIM y activaste el aprovisionamiento automático para 6 usuarios.
  2. El valor es demasiado largo: Tu valor, p.ej., el ID de correo electrónico, es demasiado largo y no es aceptable para tu aplicación basada en SCIM.
  3. Debe tener al menos un derecho, uno de los cuales debe ser el ID de perfil.
  4. El nombre de usuario ya existe. Debe ser único en toda la organización.
  5. No se encontró el recurso (usuario) en el proveedor de servicios (SP).
  6. El valor del ID de usuario de SCIM no es válido.
Corrige el error y vuelve a intentarlo después de guardar los cambios.
45004

Se produjo un error entre el proveedor de servicios y Google como proveedor de identidad. El texto del error es "Error interno: Se superó la cuota".

Posibles motivos:

  • Una interrupción que afecta al proveedor de servicios
  • El servidor del proveedor de servicios no funciona
Comunícate con el proveedor de servicios.
45005 No se puede acceder al extremo de SCIM que configuraste. Verifica el extremo de SCIM que proporcionaste en la Consola del administrador. Corrige el error y vuelve a intentarlo después de guardar los cambios.
45006

La solicitud de actualización, creación o eliminación de recursos no se creó correctamente o no fue aceptada por la aplicación basada en SCIM. Consulta los detalles del error en el archivo de errores descargado.

Posibles motivos:

  1. El valor es demasiado largo
  2. No hay suficientes licencias
  3. La licencia no es válida
  4. El valor del derecho no existe
Corrige el error y vuelve a intentarlo después de guardar los cambios.
45016

Tu aplicación basada en SCIM no aceptó la solicitud de actualización, creación o eliminación de recursos porque no ingresaste un campo obligatorio. Consulta los detalles del error en el archivo de errores descargado.

Corrige el error y vuelve a intentarlo después de guardar los cambios.