Podczas konfigurowania automatycznej obsługi administracyjnej w aplikacjach opartych na SAML mogą wystąpić te błędy:
- Błędy występujące podczas konfiguracji
- Błędy automatycznej obsługi administracyjnej w czasie działania
- Błędy na poziomie zasobów
Poniżej znajdziesz informacje na temat debugowania i naprawiania tych błędów.
Błędy występujące podczas konfiguracji
Błąd kodu autoryzacji
Ten błąd pojawia się, gdy nie można wymienić kodu autoryzacji na token odświeżania. Może się to zdarzyć, jeśli kod autoryzacji był nieprawidłowy lub jeśli zbyt długo czekasz między autoryzacją a kliknięciem Zapisz zmiany. Aby rozwiązać ten problem, jeszcze raz przeprowadź autoryzację i zapisz zmiany.
| Komunikat o błędzie | Rozwiązanie |
|---|---|
| Nie udało się wygenerować tokena autoryzacji. | Jeszcze raz przeprowadź autoryzację i zapisz zmiany. |
Błąd nieaktualnej strony
Błędy nieaktualnej strony występują, gdy strona w przeglądarce użytkownika nie została odświeżona, a konfiguracja została zmieniona poza tą sesją przeglądarki (w innym oknie przeglądarki lub przez innego użytkownika). Oto powiązane błędy, które możesz zobaczyć:
| Komunikat o błędzie | Rozwiązanie |
|---|---|
| Twoja strona jest nieaktualna. Istnieje konfiguracja obsługi administracyjnej. | Odśwież, aby zastąpić istniejącą konfigurację. |
| Twoja strona jest nieaktualna. Nie istnieje konfiguracja obsługi administracyjnej. | Odśwież, aby zastąpić istniejącą konfigurację. |
| Twoja strona jest nieaktualna. Nie można aktywować nieustawionej konfiguracji obsługi administracyjnej. | Odśwież, aby zastąpić istniejącą konfigurację. |
| Twoja strona jest nieaktualna. Nie można usunąć nieustawionej konfiguracji obsługi administracyjnej. | Odśwież, aby zastąpić istniejącą konfigurację. |
Przejściowy błąd strony
Te błędy są przejściowe i powinny zniknąć po odświeżeniu strony lub ponowieniu działania po pewnym czasie.
| Komunikat o błędzie | Rozwiązanie |
|---|---|
| Nie udało się pobrać konfiguracji obsługi administracyjnej | Odśwież stronę. |
| Nie udało się pobrać wstępnej konfiguracji obsługi administracyjnej | Odśwież stronę. |
| Nie udało się pobrać stanu obsługi administracyjnej | Odśwież stronę. |
| Nie udało się aktywować obsługi administracyjnej | Ponów próbę aktywowania obsługi administracyjnej. |
| Podczas usuwania konfiguracji obsługi administracyjnej wystąpił błąd | Ponów próbę usunięcia konfiguracji. |
| Nie udało się utworzyć konfiguracji obsługi administracyjnej | Ponownie utwórz konfigurację udostępniania i zapisz zmiany. |
| Nie udało się zaktualizować konfiguracji obsługi administracyjnej | Ponownie zaktualizuj konfigurację udostępniania i zapisz zmiany. |
| Nie udało się pobrać atrybutów niestandardowych | Ponów próbę zapisania atrybutów niestandardowych. |
| Nie udało się zaktualizować mapowania atrybutów | Ponownie zaktualizuj mapowanie atrybutów. |
| Nie udało się zaktualizować ustawień grupy dla automatycznej obsługi administracyjnej | Ponownie zaktualizuj ustawienia grupy. |
| Nie udało się zaktualizować konfiguracji wyłączenia obsługi | Ponownie zaktualizuj konfigurację usuwania kont. |
| Konfiguracja została usunięta, ale nie udało się unieważnić dostępu klienta API |
W przypadku usunięcia konfiguracji odbieramy uprawnienia zapewniające aplikacji dostęp do Twoich danych w Google. |
| Podczas aktualizowania konfiguracji obsługi administracyjnej wystąpił błąd | Odśwież stronę. |
| Uwierzytelnianie nie powiodło się | Dane uwierzytelniające (np. token dostępu) podane w konfiguracji są nieprawidłowe. Wpisz poprawne dane. |
| Podany adres URL punktu końcowego systemu SCIM jest nieprawidłowy. | Podany punkt końcowy jest nieprawidłowy. Wpisz poprawny adres URL. |
| Nie udało się włączyć obsługi administracyjnej | Przesuń suwak Automatyczna obsługa administracyjna na pozycję Aktywna. |
| Podczas usuwania konfiguracji obsługi administracyjnej wystąpił błąd |
|
| Nie udało się pobrać atrybutów od docelowego dostawcy usług |
|
| Nie udało się pobrać docelowego schematu zasobów | Sprawdź adres URL punktu końcowego podany podczas konfiguracji automatycznej obsługi administracyjnej i ponów próbę mapowania atrybutów Cloud Directory na atrybuty aplikacji docelowej. |
Błędy środowiska wykonawczego automatycznej obsługi administracyjnej
Błędy środowiska wykonawczego automatycznego udostępniania mogą wystąpić z powodu problemów z dostępem do interfejsu API, autoryzacją lub konfiguracją.
Błędy w wewnętrznych usługach Google
| Kod błędu | Opis i rozwiązanie |
|---|---|
| 17003 17006 17008 |
Description: Nie udało się przeprowadzić uwierzytelnienia w wewnętrznych usługach Google. Przyczyna: Uprawnienia zostały cofnięte w przypadku tego identyfikatora klienta do obsługi użytkowników: 910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com Rozdzielczość: Upewnij się, że ten identyfikator ma uprawnienia do tych zakresów: https://www.googleapis.com/auth/admin.directory.user.readonly, W konsoli administracyjnej użyj opcji „Zarządzaj dostępem klienta API” w sekcji Zabezpieczenia > Ustawienia zaawansowane, aby sprawdzić, czy identyfikator klienta ma te zakresy, lub dodać je do tego identyfikatora. |
| 17007 |
Description: Nie udało się przyznać dostępu do aplikacji, które obsługują automatyczne udostępnianie za pomocą przekazywania uprawnień w całej domenie. Nie udało się przyznać usłudze automatycznego udostępniania uprawnień do przekazywania dostępu w całej domenie. Jest to niezbędne do tego, by usługa automatycznej obsługi administracyjnej mogła odczytywać katalog Google. Przyczyny: Powód 1: uprawnienia zostały cofnięte w przypadku identyfikatora klienta do obsługi użytkowników. Rozdzielczości: W konsoli administracyjnej użyj opcji „Zarządzaj dostępem klientów interfejsu API” w sekcji Bezpieczeństwo > Ustawienia zaawansowane, aby dodać te identyfikator klienta i zakresy: Identyfikator klienta: Zakresy: https://www.googleapis.com/auth/admin.directory.user.readonly, Innym rozwiązaniem jest usunięcie aplikacji, której dotyczy problem, a następnie dodanie jej ponownie. Przyczyna 2. Nieoczekiwane błędy systemu Rozdzielczość: W większości przypadków ten problem zostanie rozwiązany automatycznie. Jeśli jednak nie zniknie po kilku godzinach, dodaj identyfikator klienta i zakresy lub usuń i ponownie dodaj aplikację, tak jak to zostało opisane powyżej dla przyczyny 1. |
Błędy tokena uwierzytelniania
| Kod błędu | Opis i przyczyna | Rozwiązanie |
|---|---|---|
| 17010 |
Nie ma wystarczających danych logowania, aby wykonywać wywołania do punktu końcowego SCIM. Przyczyna: token uwierzytelniania został unieważniony. |
Spróbuj ponownie autoryzować, klikając Automatyczna obsługa administracyjna, aby otworzyć Ustawienia, a następnie Ponownie autoryzuj. |
| 17013 |
Podczas pobierania tokena dostępu od dostawcy usług wystąpił błąd. Przyczyna: token uwierzytelniania został unieważniony. |
Jeśli ten błąd nie zniknie automatycznie po pewnym czasie, spróbuj ponownie autoryzować, klikając Automatyczne udostępnianie, aby otworzyć Ustawienia, a następnie Ponownie autoryzuj. |
Błędy tokena dostępu
| Kod błędu | Opis i przyczyna | Rozdzielczość |
|---|---|---|
| 17002 17011 |
Nie udało się wygenerować tokena dostępu. Przyczyna: niektóre wewnętrzne usługi Google są obecnie niedostępne. |
Ten błąd powinien zniknąć automatycznie po pewnym czasie. |
| 17009 | Błąd generowania tokena dostępu z tokena odświeżania. | Spróbuj ponownie autoryzować, klikając Automatyczna obsługa administracyjna, aby otworzyć Ustawienia, a następnie Ponownie autoryzuj. |
Błędy ogólne
| Kod błędu | Opis i przyczyna | Rozwiązanie |
|---|---|---|
| 1200x |
Błąd wewnętrzny. |
Ten błąd powinien zniknąć automatycznie po pewnym czasie. |
| 25001 | Tymczasowy brak dostępu do backendu/usługi Google. | Ponownie skonfiguruj automatyczną obsługę administracyjną. |
| 25002 |
Tymczasowy brak dostępu do serwera/usługi Google. Przyczyna: aplikacja nie jest zainstalowana dla klienta. |
Zainstaluj aplikację, a potem ponownie skonfiguruj automatyczną obsługę. |
| 25005 | Tymczasowy brak dostępu do backendu/usługi Google. | Ten błąd powinien zniknąć automatycznie po pewnym czasie. |
| 25016 | Tymczasowy brak dostępu do backendu/usługi Google. | Ponownie skonfiguruj automatyczną obsługę administracyjną. |
| 50001 | Błąd wewnętrzny. | Ten błąd powinien zniknąć automatycznie po pewnym czasie. |
| 50003 | Błąd wewnętrzny. | Ten błąd powinien zniknąć automatycznie po pewnym czasie. |
| 50005 | Usunięta grupa jest obecna w skonfigurowanych filtrach grup. | Wyklucz usuniętą grupę z ustawień zakresu obsługi administracyjnej. |
| 50006 | Błąd wewnętrzny. | Ten błąd powinien zniknąć automatycznie po pewnym czasie. |
Błędy na poziomie zasobów
Jeśli w sekcji Automatyczna obsługa administracyjna na stronie ustawień aplikacji SAML wyświetla się Niepowodzenia, kliknij Pobierz listę. Pobrany plik zawiera listę nieudanych działań tworzenia, usuwania lub aktualizowania oraz kod błędu i opis każdego niepowodzenia.
Te błędy dotyczą tylko określonych zasobów w pliku.
| Kod błędu | Opis błędu | Rozwiązanie |
|---|---|---|
| 45003 |
Żądanie aktualizacji, utworzenia lub usunięcia zasobu nie zostało zaakceptowane przez aplikację opartą na SCIM. Sprawdź szczegóły błędu w pobranym pliku błędu. Możliwe przyczyny:
|
Popraw błąd i spróbuj jeszcze raz po zapisaniu zmian. |
| 45004 |
Wystąpił błąd między dostawcą usług a Google jako dostawcą tożsamości. Tekst błędu: „Internal error - Quota Exceeded” („Błąd wewnętrzny – przekroczono limit”).
|
Skontaktuj się z dostawcą usług. |
| 45005 | Skonfigurowany punkt końcowy systemu SCIM jest nieosiągalny. Sprawdź punkt końcowy systemu SCIM podany w konsoli administracyjnej. | Popraw błąd i spróbuj jeszcze raz po zapisaniu zmian. |
| 45006 |
Żądanie aktualizacji, utworzenia lub usunięcia zasobu nie zostało poprawnie utworzone lub nie zostało zaakceptowane przez aplikację opartą na SCIM. Sprawdź szczegóły błędu w pobranym pliku błędu. Możliwe przyczyny:
|
Popraw błąd i spróbuj jeszcze raz po zapisaniu zmian. |
| 45016 |
Żądanie aktualizacji, utworzenia lub usunięcia zasobu nie zostało zaakceptowane przez aplikację opartą na SCIM, ponieważ nie wypełniono wymaganego pola. Sprawdź szczegóły błędu w pobranym pliku błędu. |
Popraw błąd i spróbuj jeszcze raz po zapisaniu zmian. |