Ao configurar o provisionamento automático para seus apps baseados em SAML, você pode encontrar estes erros:
- Falhas no tempo de configuração
- Falhas no tempo de execução do provisionamento automático
- Falhas no nível do recurso
Veja abaixo como depurar e resolver esses erros.
Falhas no tempo de configuração
Erro de código de autorização
Esse erro aparece quando não é possível trocar o código de autorização por um token de atualização. Isso pode acontecer se o código de autorização estiver incorreto ou se você demorar muito entre a autorização e o clique em Salvar alterações. Para resolver esse erro, basta autorizar novamente e salvar as alterações.
| Mensagem de erro | Resolução |
|---|---|
| Não foi possível gerar o token de autorização. | Tente fazer a autorização novamente e salve as alterações. |
Erro de página desatualizada
Os erros de página desatualizada ocorrem quando a página do navegador do usuário não é atualizada e a configuração muda fora da sessão do navegador (em outra janela do navegador ou por causa de outro usuário). Confira os erros associados que podem aparecer:
| Mensagem de erro | Resolução |
|---|---|
| Sua página está desatualizada. A configuração de provisionamento existe. | Atualize para substituir a configuração atual. |
| Sua página está desatualizada. A configuração de provisionamento não existe. | Atualize para substituir a configuração atual. |
| Sua página está desatualizada. Não é possível ativar uma configuração de provisionamento não definida. | Atualize para substituir a configuração atual. |
| Sua página está desatualizada. Não é possível excluir uma configuração de provisionamento não definida. | Atualize para substituir a configuração atual. |
Erro de página temporário
Esses erros são temporários e serão resolvidos se você atualizar a página ou tentar a ação novamente depois de um tempo.
| Mensagem de erro | Resolução |
|---|---|
| Não foi possível coletar a configuração de aprovisionamento | Atualize a página. |
| Não foi possível buscar a pré-configuração do aprovisionamento | Atualize a página. |
| Não foi possível buscar o status de aprovisionamento | Atualize a página. |
| Falha na ativação do provisionamento | Tente ativar o provisionamento novamente. |
| Ocorreu um erro ao excluir a configuração de provisionamento | Tente excluir a configuração novamente. |
| Não foi possível criar a configuração de provisionamento | Crie a configuração de provisionamento novamente e salve as mudanças. |
| Não foi possível atualizar a configuração de provisionamento | Atualize a configuração de provisionamento novamente e salve as mudanças. |
| Não foi possível buscar atributos personalizados | Tente salvar os atributos personalizados novamente. |
| Não foi possível atualizar o mapeamento de atributos | Atualize o mapeamento de atributos novamente. |
| Não foi possível atualizar as configurações de grupo para o provisionamento automático | Atualize as configurações do grupo novamente. |
| Não foi possível atualizar a configuração de desprovisionamento | Atualize a configuração de desprovisionamento novamente. |
| A configuração foi excluída, mas não foi possível revogar o acesso do cliente à API |
Ao excluir a configuração, revogamos as permissões para os apps acessarem seus dados no Google. |
| Erro ao atualizar a configuração de provisionamento | Atualize a página. |
| Falha na autenticação. | As credenciais de autenticação (por exemplo, token de acesso) fornecidas na configuração estão incorretas. Digite as credenciais corretas. |
| O URL do endpoint SCIM fornecido é inválido | O endpoint de destino fornecido era inválido. Digite o URL correto. |
| Ocorreu um erro ao ativar o provisionamento | Mova o controle deslizante Provisionamento automático para Ativo. |
| Ocorreu um erro ao excluir a configuração de provisionamento |
|
| Não foi possível buscar atributos do provedor de serviços de destino |
|
| Não foi possível buscar o esquema do recurso de destino | Verifique o URL do endpoint informado durante a configuração do provisionamento de usuários e tente mapear os atributos do Cloud Directory para os do app de destino novamente. |
Falhas de tempo de execução do provisionamento automático
Falhas de tempo de execução do provisionamento automático podem ocorrer devido a problemas de acesso à API, autorização ou configuração.
Erros de serviços internos do Google
| Código do erro | Descrição e resolução |
|---|---|
| 17003 17006 17008 |
Descrição: Não foi possível autenticar com os serviços internos do Google. Motivo: As permissões foram revogadas do ID do cliente de provisionamento de usuário: 910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com Resolução: Verifique se o código tem permissões para os seguintes escopos: https://www.googleapis.com/auth/admin.directory.user.readonly, No Admin Console, use Gerenciar acesso do cliente da API em Segurança > Configurações avançadas para verificar se o ID do cliente tem esses escopos ou para adicioná-los a ele. |
| 17007 |
Descrição: Não foi possível conceder acesso a apps que oferecem suporte ao provisionamento automático usando a delegação de autoridade em todo o domínio. Não foi possível conceder autoridade de delegação em todo o domínio ao serviço de provisionamento automático. Isso é fundamental para que o serviço de provisionamento automático leia o diretório do Google. Motivos: Motivo 1:as permissões foram revogadas do ID do cliente de provisionamento de usuários. Resoluções: No Admin Console, use Gerenciar acesso do cliente da API em Segurança > Configurações avançadas para adicionar o ID do cliente e os escopos a seguir: ID do cliente: Escopos: https://www.googleapis.com/auth/admin.directory.user.readonly, Uma alternativa é excluir o app e adicioná-lo novamente. Motivo 2:erros inesperados do sistema Resolução: Na maioria dos casos, este erro é resolvido automaticamente. Se o problema persistir depois de algumas horas, adicione o ID do cliente e os escopos ou exclua e adicione novamente o app, conforme mencionado no motivo 1. |
Erros de token de autenticação
| Código do erro | Descrição e motivo | Resolução |
|---|---|---|
| 17010 |
Não há credenciais suficientes para fazer chamadas ao seu endpoint SCIM. Motivo: o token de autenticação foi revogado. |
Clique em Provisionamento automático para abrir as configurações e em Reautorizar. |
| 17013 |
Ocorreu um erro ao buscar um token de acesso do seu provedor de serviços. Motivo: o token de autenticação foi revogado. |
Se esse erro não for resolvido automaticamente depois de algum tempo, tente autorizar novamente clicando em Provisionamento automático para abrir as configurações e, em seguida, Autorizar novamente. |
Erros de token de acesso
| Código do erro | Descrição e motivo | Resolução |
|---|---|---|
| 17002 17011 |
Não foi possível gerar um token de acesso. Motivo: alguns serviços internos do Google não estão disponíveis no momento. |
Este erro costuma ser resolvido automaticamente após algum tempo. |
| 17009 | Falha na geração do token de acesso a partir do token de atualização. | Clique em Provisionamento automático para abrir as configurações e em Reautorizar. |
Erros gerais
| Código do erro | Descrição e motivo | Resolução |
|---|---|---|
| 1200x |
Erro interno |
Este erro costuma ser resolvido automaticamente após algum tempo. |
| 25001 | O back-end/serviço do Google está temporariamente indisponível. | Configure o provisionamento automático novamente. |
| 25002 |
O back-end/serviço do Google está temporariamente indisponível. Motivo: o app não foi instalado para o cliente. |
Instale o aplicativo e configure o provisionamento automático de novo. |
| 25005 | O back-end/serviço do Google está temporariamente indisponível. | Este erro costuma ser resolvido automaticamente após algum tempo. |
| 25016 | O back-end/serviço do Google está temporariamente indisponível. | Configure o provisionamento automático novamente. |
| 50001 | Erro interno | Este erro costuma ser resolvido automaticamente após algum tempo. |
| 50003 | Erro interno | Este erro costuma ser resolvido automaticamente após algum tempo. |
| 50005 | Um grupo excluído está presente nos filtros de grupo configurados. | Remova o grupo excluído da configuração do escopo de provisionamento. |
| 50006 | Erro interno | Este erro costuma ser resolvido automaticamente após algum tempo. |
Falhas no nível do recurso
Se a seção "Provisionamento automático" na página de configurações do app SAML mostrar Falhas, clique em Baixar lista. O arquivo baixado lista as ações de criação, exclusão ou atualização com falha, além de um código de erro e uma descrição para cada falha.
Esses erros afetam apenas os recursos especificados no arquivo.
| Código do erro | Descrição do erro | Resolução |
|---|---|---|
| 45003 |
A solicitação de atualização, criação ou exclusão de recursos não foi aceita pelo seu aplicativo baseado em SCIM. Analise os detalhes do erro no arquivo de erro transferido por download. Motivos possíveis:
|
Corrija o erro e tente novamente após salvar as alterações. |
| 45004 |
Ocorreu um erro entre o provedor de serviços e o Google como provedor de identidade. O texto de erro é "Erro interno: cota excedida".
|
Entre em contato com o provedor de serviços. |
| 45005 | O endpoint SCIM que você configurou está inacessível. Verifique o endpoint SCIM que você informou no Admin Console. | Corrija o erro e tente novamente após salvar as alterações. |
| 45006 |
A solicitação de atualização, criação ou exclusão do recurso não foi criada corretamente ou não foi aceita pelo aplicativo baseado em SCIM. Analise os detalhes do erro no arquivo de erro transferido por download. Motivos possíveis:
|
Corrija o erro e tente novamente após salvar as alterações. |
| 45016 |
A solicitação de atualização, criação ou exclusão de recursos não foi aceita pelo seu aplicativo baseado em SCIM porque você não preencheu um campo obrigatório. Analise os detalhes do erro no arquivo de erro transferido por download. |
Corrija o erro e tente novamente após salvar as alterações. |