Как посмотреть ошибки автосинхронизации

При настройке автоматической инициализации аккаунтов для приложений на основе SAML могут возникать следующие ошибки:

Ниже рассказывается, как устранить эти ошибки.

Ошибки этапа настройки

Ошибка кода авторизации

Эта ошибка возникает, когда код авторизации не удается обменять на токен обновления. Это может произойти, если код авторизации был введен неправильно или если вы слишком долго ждали между авторизацией и нажатием кнопки Сохранить изменения. Чтобы устранить эту ошибку, повторите авторизацию и сохраните изменения.

Сообщение об ошибке Решение
Не удалось сгенерировать токен авторизации. Повторите попытку и сохраните изменения.

Ошибка устаревшей страницы

Эти ошибки возникают, если страница браузера не обновлялась, в то время как настройки были изменены в другом окне браузера или другим пользователем. Ниже перечислены связанные ошибки, которые могут возникнуть:

Сообщение об ошибке Решение
Данные на странице устарели. Конфигурация синхронизации настроена. Чтобы переопределить существующие настройки, обновите страницу.
Данные на странице устарели. Конфигурация синхронизации отсутствует. Чтобы переопределить существующие настройки, обновите страницу.
Данные на странице устарели. Активировать ненастроенную конфигурацию синхронизации нельзя. Чтобы переопределить существующие настройки, обновите страницу.
Данные на странице устарели. Удалить ненастроенную конфигурацию синхронизации нельзя. Чтобы переопределить существующие настройки, обновите страницу.

Временная ошибка страницы

Эти ошибки временные, и их можно устранить, обновив страницу или повторив действие через некоторое время.

Сообщение об ошибке Решение
Не удалось загрузить настройки синхронизации. Обновите страницу.
Не удалось загрузить предварительные настройки синхронизации. Обновите страницу.
Не удалось загрузить статус синхронизации. Обновите страницу.
Не удалось активировать синхронизацию. Повторите попытку.
Не удалось удалить настройки синхронизации. Повторите попытку.
Не удалось создать настройку синхронизации. Заново настройте инициализацию и сохраните изменения.
Не удалось обновить настройку синхронизации. Снова обновите настройки инициализации и сохраните изменения.
Не удалось получить настраиваемые атрибуты Повторите попытку.
Не удалось обновить сопоставление атрибутов. Ещё раз обновите сопоставление атрибутов.
Не удалось обновить настройки группы для автосинхронизации. Снова измените настройки группы.
Не удалось обновить конфигурацию отключения. Ещё раз обновите конфигурацию отзыва доступа.
Конфигурация удалена, но запретить доступ клиента API не удалось.

При удалении конфигурации отменяются разрешения, которые позволяют приложению обращаться к вашим данным в сервисах Google.

Если по какой-либо причине это не удастся, отмените доступ вручную, выбрав Управление доступом API-клиентов в разделе Безопасность.

Если вы удалили конфигурацию и планируете настроить ее снова, никаких действий не требуется.

Не удалось обновить настройки синхронизации. Обновите страницу.
Ошибка аутентификации. Учетные данные для аутентификации (например, токен носителя), указанные в конфигурации, неверны. Задайте правильные учетные данные.
Введенный вами URL конечной точки системы кросс-доменного управления учетными данными (SCIM) недействителен. URL конечной точки недействителен. Введите правильный URL.
Не удалось включить синхронизацию. Переместите ползунок Автоинициализация в положение Включено.
Не удалось удалить настройки синхронизации.
  1. Нажмите Автосинхронизация, чтобы открыть настройки.
  2. В разделе Удаление конфигурации нажмите Удалить.
Не удалось загрузить атрибуты целевого поставщика услуг.
  1. Нажмите Автосинхронизация, чтобы открыть настройки.
  2. В разделе Сопоставление атрибутов нажмите Изменить.
  3. Внесите нужные изменения.
Не удалось загрузить набор атрибутов целевого ресурса. Проверьте URL конечной точки, указанный при настройке автосинхронизации, и повторите сопоставление атрибутов облачного каталога с атрибутами целевого приложения.

Ошибки автоинициализации во время выполнения

Во время автоинициализации могут возникать ошибки, связанные с доступом к API, авторизацией или конфигурацией.

Ошибки внутренних сервисов Google

Код ошибки Описание и решение
17003
17006
17008

Описание

Не удалось пройти аутентификацию во внутренних сервисах Google.

Причина

У этого идентификатора клиента для инициализации пользователей были отозваны разрешения:

910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

Разрешение

Убедитесь, что у данного идентификатора есть разрешения на доступ к следующим областям:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

В консоли администратора выберите Управление доступом клиента API в разделе Безопасность > Расширенные настройки, чтобы проверить, есть ли у идентификатора клиента эти области действия, или добавить их.

17007

Описание

Не удалось предоставить доступ к приложениям, поддерживающим автоматическую инициализацию с использованием делегирования доступа к данным в домене.

Не удалось предоставить сервису автоинициализации полномочия на делегирование доступа к данным в домене. Без этих прав сервис автосинхронизации не сможет читать каталог Google.

Причины

Причина 1. У идентификатора клиента для инициализации пользователя были отозваны разрешения.

Решения

В консоли администратора выберите Управление доступом клиента API в разделе Безопасность > Расширенные настройки, чтобы добавить следующие идентификатор клиента и области действия:

Идентификатор клиента:
910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

Области действия:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

Вы также можете удалить приложение, с которым возникла проблема, а затем добавить его снова.

Причина 2. Непредвиденные системные ошибки

Разрешение

Как правило, эта проблема решается автоматически. Если она не решилась через несколько часов, добавьте идентификатор клиента и области действия или удалите и повторно добавьте приложение, как описано выше в инструкциях для причины 1.

Ошибки токена аутентификации

Код ошибки Описание и причина Решение
17010

Недостаточно учетных данных для вызова конечной точки SCIM.

Причина: токен авторизации аннулирован.

Попробуйте повторно авторизоваться. Для этого нажмите Автоинициализация, чтобы открыть настройки, а затем выберите Повторно авторизоваться.
17013

Ошибка получения токена доступа у поставщика услуг.

Причина: токен авторизации аннулирован.

Если ошибка не исчезнет автоматически через некоторое время, попробуйте повторно авторизоваться. Для этого нажмите Автоматическая инициализация, чтобы открыть настройки, а затем выберите Повторно авторизоваться.

Ошибки доступа к токену

Код ошибки Описание и причина разрешение.
17002
17011

Не удалось создать токен доступа.

Причина: сейчас некоторые внутренние сервисы Google недоступны.

Проблема должна устраниться автоматически.
17009 Не удалось создать токен доступа из токена обновления. Попробуйте повторно авторизоваться. Для этого нажмите Автоинициализация, чтобы открыть настройки, а затем выберите Повторно авторизоваться.

Общие ошибки

Код ошибки Описание и причина Решение
1200x

Внутренняя ошибка

Проблема должна устраниться автоматически.
25001 Сервер или сервис Google временно недоступны. Настройте автосинхронизацию ещё раз.
25002

Сервер или сервис Google временно недоступны.

Причина: у клиента не установлено приложение.

Установите приложение и настройте автоматическую инициализацию заново.
25005 Сервер или сервис Google временно недоступны. Проблема должна устраниться автоматически.
25016 Сервер или сервис Google временно недоступны. Настройте автосинхронизацию ещё раз.
50001 Внутренняя ошибка Проблема должна устраниться автоматически.
50003 Внутренняя ошибка Проблема должна устраниться автоматически.
50005 Удаленная группа присутствует в настроенных фильтрах групп. Удалите данную группу из области синхронизации.
50006 Внутренняя ошибка Проблема должна устраниться автоматически.

Ошибки уровня ресурсов

Если в разделе "Автоинициализация" на странице настроек приложения SAML указано Сбои, нажмите Скачать список. В скачанном файле перечислены неудачные попытки создать, удалить или обновить объекты, а также код и описание каждой ошибки.

Эти ошибки влияют только на указанные ресурсы в файле.

Код ошибки Описание ошибки Решение
45003

Приложение на базе системы кросс-доменного управления учетными данными (SCIM) не принимает запрос на обновление, создание или удаление ресурса. Подробное описание ошибки содержится в файле, который можно скачать.

Возможные причины:

  1. Превышено максимальное количество лицензий. В приложении на базе SCIM можно создать 5 пользователей, а вы включили автосинхронизацию для 6 пользователей.
  2. Слишком длинное значение. Например, идентификатор сообщения содержит слишком много символов, поэтому приложение его не принимает.
  3. Должен быть указан хотя бы один параметр, одним из которых должен быть идентификатор профиля.
  4. Имя пользователя уже существует. Оно должно быть уникальным в масштабах организации.
  5. Ресурс (пользователь) не найден на стороне поставщика.
  6. Недопустимое значение идентификатора пользователя SCIM.
После устранения ошибки сохраните изменения и повторите попытку.
45004

Произошла ошибка при передаче данных между поставщиком услуг и Google в качестве поставщика идентификационной информации. Текст ошибки: "Внутренняя ошибка – превышена квота".

Возможные причины:

  • Сбой, повлиявший на работу поставщика услуг.
  • Сервер поставщика услуг не работает.
Обратитесь к поставщику услуг.
45005 Конечная точка системы кросс-доменного управления учетными данными (SCIM) недоступна. Проверьте данные в консоли администратора. После устранения ошибки сохраните изменения и повторите попытку.
45006

Приложение на базе системы кросс-доменного управления учетными данными (SCIM) не принимает запрос на обновление, создание или удаление ресурса. Подробное описание ошибки содержится в файле, который можно скачать.

Возможные причины:

  1. слишком длинное значение;
  2. недостаточно лицензий;
  3. недействительная лицензия;
  4. Значение времени доступа не существует
После устранения ошибки сохраните изменения и повторите попытку.
45016

Приложение на базе системы кросс-доменного управления учетными данными (SCIM) не принимает запрос на обновление, создание или удаление ресурса, поскольку обязательное поле не заполнено. Подробное описание ошибки содержится в файле, который можно скачать.

После устранения ошибки сохраните изменения и повторите попытку.