Bei der Konfiguration der automatischen Bereitstellung für Ihre SAML-basierten Apps können die folgenden Fehler auftreten:
- Fehler während der Konfiguration
- Laufzeitfehler bei der automatischen Nutzerverwaltung
- Fehler auf Ressourcenebene
Sie finden weiter unten Informationen dazu, wie Sie diese Fehler beheben.
Fehler während der Konfiguration
Fehler beim Autorisierungscode
Dieser Fehler wird angezeigt, wenn der Autorisierungscode nicht gegen ein Aktualisierungstoken eingetauscht werden konnte. Das kann passieren, wenn Ihr Autorisierungscode falsch ist oder wenn Sie zu lange zwischen der Autorisierung und dem Klicken auf Änderungen speichern warten. Dieser Fehler wird in der Regel behoben, wenn Sie die Autorisierung wiederholen und die Änderungen noch einmal speichern.
| Fehlermeldung | Lösung |
|---|---|
| Das Autorisierungstoken konnte nicht erzeugt werden. | Wiederholen Sie die Autorisierung und speichern Sie die Änderungen noch einmal. |
Fehler bei einer veralteten Seite
Fehler wegen veralteter Seiten treten auf, wenn die Browserseite des Nutzers nicht aktualisiert und die Konfiguration außerhalb dieser Browsersitzung geändert wurde, entweder in einem anderen Browserfenster oder durch einen anderen Nutzer. Folgende zugehörige Fehler können auftreten:
| Fehlermeldung | Lösung |
|---|---|
| Ihre Seite ist veraltet. Die Nutzerverwaltung wurde bereits eingerichtet. | Aktualisieren Sie die Seite, um die bestehende Einrichtung zu überschreiben. |
| Ihre Seite ist veraltet. Die Nutzerverwaltung wurde noch nicht eingerichtet. | Aktualisieren Sie die Seite, um die bestehende Einrichtung zu überschreiben. |
| Ihre Seite ist veraltet. Eine nicht konfigurierte Einrichtung der Nutzerverwaltung kann nicht aktiviert werden. | Aktualisieren Sie die Seite, um die bestehende Einrichtung zu überschreiben. |
| Ihre Seite ist veraltet. Eine nicht konfigurierte Einrichtung der Nutzerverwaltung kann nicht gelöscht werden. | Aktualisieren Sie die Seite, um die bestehende Einrichtung zu überschreiben. |
Vorübergehender Fehler auf einer Seite
Diese Fehler sind vorübergehend und sollten behoben werden, wenn Sie die Seite aktualisieren oder die Aktion nach einiger Zeit wiederholen.
| Fehlermeldung | Lösung |
|---|---|
| Die Konfiguration der Nutzerverwaltung konnte nicht abgerufen werden. | Aktualisieren Sie die Seite. |
| Die Vorkonfiguration der Nutzerverwaltung konnte nicht abgerufen werden. | Aktualisieren Sie die Seite. |
| Der Status der Nutzerverwaltung konnte nicht abgerufen werden. | Aktualisieren Sie die Seite. |
| Bei der Aktivierung der Nutzerverwaltung ist ein Fehler aufgetreten. | Versuchen Sie noch einmal, die Nutzerverwaltung zu aktivieren. |
| Fehler beim Löschen der Nutzerverwaltungskonfiguration. | Versuchen Sie noch einmal, die Konfiguration zu löschen. |
| Die Nutzerverwaltungskonfiguration konnte nicht erstellt werden. | Erstellen Sie die Einrichtung für die Bereitstellung noch einmal und speichern Sie Ihre Änderungen. |
| Die Nutzerverwaltungskonfiguration konnte nicht aktualisiert werden. | Aktualisieren Sie die Einrichtung der Bereitstellung noch einmal und speichern Sie die Änderungen. |
| Benutzerdefinierte Attribute konnten nicht abgerufen werden | Versuchen Sie noch einmal, die benutzerdefinierten Attribute zu speichern. |
| Die Attributszuordnung konnte nicht aktualisiert werden. | Aktualisieren Sie die Attributzuordnung noch einmal. |
| Die Gruppeneinstellungen für die automatische Nutzerverwaltung konnten nicht aktualisiert werden. | Aktualisieren Sie die Gruppeneinstellungen noch einmal. |
| Die Konfiguration für das Deaktivieren der Nutzerverwaltung konnte nicht aktualisiert werden. | Aktualisieren Sie die Konfiguration für die Aufhebung der Bereitstellung noch einmal. |
| Die Konfiguration wurde gelöscht, der Zugriff des API-Clients konnte aber nicht widerrufen werden. |
Wenn Sie eine Konfiguration löschen, widerrufen wir die Berechtigungen, durch die Ihre Anwendung auf die Daten von Google zugreifen kann. |
| Fehler beim Aktualisieren der Nutzerverwaltungskonfiguration. | Aktualisieren Sie die Seite. |
| Fehler bei der Authentifizierung. | Die in der Konfiguration angegebenen Authentifizierungsanmeldedaten (z.B. das Bearer-Token) sind falsch. Geben Sie die richtigen Anmeldedaten ein. |
| Die bereitgestellte URL für den SCIM-Endpunkt ist ungültig. | Der von Ihnen angegebene Endpunkt war ungültig. Geben Sie die richtige URL ein. |
| Fehler beim Aktivieren der Nutzerverwaltung. | Stellen Sie den Schieberegler für die Automatische Nutzerverwaltung auf Aktiv. |
| Fehler beim Löschen der Nutzerverwaltungskonfiguration. |
|
| Attribute von Ihrem Ziel-Dienstanbieter konnten nicht abgerufen werden. |
|
| Zielressourcenschema konnte nicht abgerufen werden. | Prüfen Sie die Endpunkt-URL, die Sie während der Einrichtung der automatischen Nutzerverwaltung angegeben haben, und versuchen Sie dann noch einmal, die Cloud Directory-Attribute den Attributen der Zielanwendung zuzuordnen. |
Laufzeitfehler bei der automatischen Bereitstellung
Laufzeitfehler bei der automatischen Bereitstellung können aufgrund von Problemen mit API-Zugriff, Autorisierung oder Konfiguration auftreten.
Fehler bei internen Google-Diensten
| Fehlercode | Beschreibung und Lösung |
|---|---|
| 17003 17006 17008 |
Description: Die Authentifizierung bei internen Google-Diensten konnte nicht durchgeführt werden. Grund: Die Berechtigungen für diese Client-ID für die Nutzerbereitstellung wurden widerrufen: 910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com Lösung: Prüfen Sie, ob diese ID Berechtigungen für die folgenden Bereiche hat: https://www.googleapis.com/auth/admin.directory.user.readonly, Verwenden Sie in der Admin-Konsole unter Sicherheit > Erweiterte Einstellungen die Option API-Clientzugriff verwalten, um zu prüfen, ob die Client-ID diese Bereiche hat, oder um diese Bereiche der Client-ID hinzuzufügen. |
| 17007 |
Description: Der Zugriff auf Apps, die die automatische Bereitstellung unterstützen, konnte nicht über die domainweite Delegierung von Berechtigungen gewährt werden. Dem Dienst für die automatische Bereitstellung konnte keine domainweite Delegierungsberechtigung erteilt werden. Ohne diese Berechtigung kann das Google-Verzeichnis nicht von der automatischen Nutzerverwaltung gelesen werden. Gründe: Grund 1:Die Berechtigungen wurden für die Client-ID für die Nutzerbereitstellung widerrufen. Auflösungen: Fügen Sie in der Admin-Konsole unter Sicherheit > Erweiterte Einstellungen mit API-Clientzugriff verwalten die folgende Client-ID und die folgenden Bereiche hinzu: Client-ID: Bereiche: https://www.googleapis.com/auth/admin.directory.user.readonly, Eine alternative Lösung besteht darin, die betreffende App zu löschen und dann wieder hinzuzufügen. Grund 2:Unerwartete Systemfehler Lösung: In den meisten Fällen wird dieser Fehler automatisch behoben. Wenn das Problem jedoch nach einigen Stunden weiterhin besteht, fügen Sie entweder die Client-ID und die Bereiche hinzu oder löschen Sie die App wie oben bei Grund 1 und fügen Sie sie dann wieder hinzu. |
Fehler bei Authentifizierungstokens
| Fehlercode | Beschreibung und Ursache | Lösung |
|---|---|---|
| 17010 |
Es sind nicht genügend Anmeldedaten vorhanden, um Aufrufe an Ihren SCIM-Endpunkt zu senden. Ursache: Das Autorisierungstoken wurde widerrufen. |
Versuchen Sie, die Autorisierung noch einmal zu erteilen. Klicken Sie dazu auf Automatische Nutzerverwaltung, um die Einstellungen zu öffnen, und dann auf Nochmal autorisieren. |
| 17013 |
Beim Abrufen eines Zugriffstokens von Ihrem Dienstanbieter ist ein Fehler aufgetreten. Ursache: Das Autorisierungstoken wurde widerrufen. |
Wenn dieser Fehler nicht automatisch nach einiger Zeit behoben wird, versuchen Sie, die Autorisierung noch einmal durchzuführen. Klicken Sie dazu auf Automatische Bereitstellung, um die Einstellungen zu öffnen, und dann auf Neu autorisieren. |
Fehler mit Zugriffstoken
| Fehlercode | Beschreibung und Ursache | Lösung |
|---|---|---|
| 17002 17011 |
Ein Zugriffstoken konnte nicht erzeugt werden. Ursache: Einige interne Google-Dienste sind derzeit nicht verfügbar. |
Dieser Fehler sollte nach einiger Zeit automatisch behoben werden. |
| 17009 | Bei der Erstellung des Zugriffstokens aus dem Aktualisierungstoken ist ein Fehler aufgetreten. | Versuchen Sie, die Autorisierung noch einmal zu erteilen. Klicken Sie dazu auf Automatische Nutzerverwaltung, um die Einstellungen zu öffnen, und dann auf Nochmal autorisieren. |
Allgemeine Fehler
| Fehlercode | Beschreibung und Ursache | Lösung |
|---|---|---|
| 1200x |
Interner Fehler |
Dieser Fehler sollte nach einiger Zeit automatisch behoben werden. |
| 25001 | Google-Back-End/-Dienst ist vorübergehend nicht verfügbar. | Richten Sie die automatische Nutzerverwaltung noch einmal ein. |
| 25002 |
Google-Back-End/-Dienst ist vorübergehend nicht verfügbar. Ursache: Die Anwendung ist für den Kunden nicht installiert. |
Installieren Sie die Anwendung und richten Sie die automatische Nutzerbereitstellung dann noch einmal ein. |
| 25005 | Google-Back-End/-Dienst ist vorübergehend nicht verfügbar. | Dieser Fehler sollte nach einiger Zeit automatisch behoben werden. |
| 25016 | Google-Back-End/-Dienst ist vorübergehend nicht verfügbar. | Richten Sie die automatische Nutzerverwaltung noch einmal ein. |
| 50001 | Interner Fehler | Dieser Fehler sollte nach einiger Zeit automatisch behoben werden. |
| 50003 | Interner Fehler | Dieser Fehler sollte nach einiger Zeit automatisch behoben werden. |
| 50005 | Eine gelöschte Gruppe ist in den konfigurierten Gruppenfiltern vorhanden. | Entfernen Sie die gelöschte Gruppe aus der Konfiguration der Nutzerverwaltung. |
| 50006 | Interner Fehler | Dieser Fehler sollte nach einiger Zeit automatisch behoben werden. |
Fehler auf Ressourcenebene
Wenn im Abschnitt „Automatische Nutzerverwaltung“ auf der Seite mit den SAML-App-Einstellungen Fehler angezeigt wird, klicken Sie auf Liste herunterladen. Die heruntergeladene Datei enthält eine Liste der fehlgeschlagenen Erstellungs-, Lösch- oder Aktualisierungsvorgänge sowie einen Fehlercode und eine Beschreibung für jeden Fehler.
Diese Fehler betreffen nur die angegebenen Ressourcen in der Datei.
| Fehlercode | Fehlerbeschreibung | Lösung |
|---|---|---|
| 45003 |
Die Anfrage zur Aktualisierung, Erstellung oder Löschung der Ressource wurde von Ihrer SCIM-basierten Anwendung nicht akzeptiert. Sehen Sie sich die Fehlerdetails in der heruntergeladenen Fehlerdatei an. Mögliche Gründe:
|
Beheben Sie den Fehler und wiederholen Sie den Vorgang, sobald Sie die Änderungen gespeichert haben. |
| 45004 |
Zwischen Dienstanbieter und Google als Identitätsanbieter ist ein Fehler aufgetreten. Der Fehlertext lautet "Interner Fehler – Kontingent überschritten".
|
Wenden Sie sich an den Dienstanbieter. |
| 45005 | Der von Ihnen konfigurierte SCIM-Endpunkt ist nicht erreichbar. Überprüfen Sie den in der Admin-Konsole angegebenen SCIM-Endpunkt. | Beheben Sie den Fehler und wiederholen Sie den Vorgang, sobald Sie die Änderungen gespeichert haben. |
| 45006 |
Die Anfrage zur Aktualisierung, Erstellung oder Löschung der Ressource wurde von der SCIM-basierten Anwendung nicht richtig erstellt oder nicht akzeptiert. Sehen Sie sich die Fehlerdetails in der heruntergeladenen Fehlerdatei an. Mögliche Gründe:
|
Beheben Sie den Fehler und wiederholen Sie den Vorgang, sobald Sie die Änderungen gespeichert haben. |
| 45016 |
Die Anfrage zum Aktualisieren, Erstellen oder Löschen der Ressource wurde von Ihrer SCIM-basierten Anwendung nicht akzeptiert, da Sie ein Pflichtfeld nicht ausgefüllt haben. Sehen Sie sich die Fehlerdetails in der heruntergeladenen Fehlerdatei an. |
Beheben Sie den Fehler und wiederholen Sie den Vorgang, sobald Sie die Änderungen gespeichert haben. |