自動プロビジョニングのエラーを表示する

SAML ベースのアプリの自動プロビジョニングを構成する際に、次のエラーが表示されることがあります。

これらのエラーのデバッグや解決方法については、以下をご覧ください。

設定時のエラー

認証コードのエラー

このエラーは、認証コードを更新トークンと交換できなかった場合に表示されます。このエラーは、認証コードが間違っている場合や、認証してから [変更を保存] をクリックするまでの時間が長すぎる場合に発生することがあります。このエラーを解決するには、再認証して変更を保存します。

エラー メッセージ 解決策
認証トークンを生成できませんでした。 認証を再試行し、変更を保存します。

ページが最新ではないことによるエラー

古いページのエラーは、ユーザーのブラウザページが更新されておらず、このブラウザ セッションの外部で構成が変更された場合(別のブラウザ ウィンドウから、または別のユーザーによって)に発生します。関連するエラーは次のとおりです。

エラー メッセージ 解決策
ページが最新ではありません。プロビジョニング設定は存在しています。 既存の設定をオーバーライドするには、ページを更新します。
ページが最新ではありません。プロビジョニング設定は現在ありません。 既存の設定をオーバーライドするには、ページを更新します。
ページが最新ではないため、未設定のプロビジョニングを有効にできません。 既存の設定をオーバーライドするには、ページを更新します。
ページが最新ではないため、未設定のプロビジョニングを削除できません。 既存の設定をオーバーライドするには、ページを更新します。

ページの一時的なエラー

これらのエラーは一時的なもので、ページを更新するか、しばらくしてから操作を再試行すると解決します。

エラー メッセージ 解決策
プロビジョニング設定を取得できませんでした ページを更新します。
プロビジョニングの事前設定を読み込めませんでした ページを更新します。
プロビジョニング ステータスを読み込めませんでした ページを更新します。
プロビジョニングを有効化できませんでした プロビジョニングの有効化を再試行します。
プロビジョニング設定の削除中にエラーが発生しました 設定の削除を再試行します。
プロビジョニング設定を作成できませんでした プロビジョニング設定をもう一度作成し、変更を保存します。
プロビジョニング設定を更新できませんでした プロビジョニング設定を再度更新し、変更を保存します。
カスタム属性を取得できませんでした カスタム属性の保存を再試行します。
属性のマッピングを更新できませんでした 属性マッピングを再度更新します。
自動プロビジョニングのグループ設定を更新できませんでした グループの設定を再度更新します。
プロビジョニング解除の設定を更新できませんでした プロビジョニング解除の構成を再度更新します。
設定は削除できましたが、API クライアント アクセスを取り消せませんでした

設定の削除時には、アプリケーションが Google 側のデータにアクセスする権限が無効になります。

何らかの理由で失敗した場合は、[セキュリティ] セクションの [API クライアント アクセスの管理] にアクセスして、手動でアクセスを取り消します。

構成を削除して再設定する予定がある場合は、対応は不要です。

プロビジョニング設定の更新中にエラーが発生しました ページを更新します。
認証に失敗しました 構成で指定された認証情報(ベアラートークンなど)が正しくありません。正しい認証情報を入力してください。
入力した SCIM エンドポイント URL が無効です 入力したターゲットのエンドポイントが無効でした。正しい URL を入力してください。
プロビジョニングの有効化中にエラーが発生しました [自動プロビジョニング] スライダーを [有効] に移動します。
プロビジョニング設定の削除中にエラーが発生しました
  1. [自動プロビジョニング] をクリックして [設定] を開きます。
  2. [設定の削除] で [削除] をクリックします。
対象のサービス プロバイダから属性を読み込めませんでした
  1. [自動プロビジョニング] をクリックして [設定] を開きます。
  2. [属性のマッピング] で [編集] をクリックします。
  3. 必要に応じてサービス プロバイダのマッピングを編集します。
対象のリソースのスキーマを読み込めませんでした 自動プロビジョニングの設定時に入力したエンドポイント URL を確認して、Cloud Directory 属性の対象アプリケーション属性へのマッピングを再試行します。

自動プロビジョニングのランタイム エラー

API アクセス、認可、構成に関する問題が原因で、ランタイムの自動プロビジョニングが失敗することがあります。

Google の内部サービスエラー

エラーコード 説明と解決策
17003
17006
17008

説明:

Google 内部のサービスで認証できませんでした。

Reason:

このユーザー プロビジョニング クライアント ID から権限が取り消されました。

910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

解決策:

この ID に次のスコープへの権限があることを確認します。

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

管理コンソールで、[セキュリティ] > [詳細設定] の [API クライアントのアクセス権を管理する] を使用して、クライアント ID にこれらのスコープがあることを確認するか、これらのスコープをこのクライアント ID に追加します。

17007

説明:

権限のドメイン全体の委任を使用して、自動プロビジョニングをサポートするアプリへのアクセス権を付与できませんでした。

自動プロビジョニング サービスにドメイン全体の委任権限を付与できませんでした。これは、自動プロビジョニング サービスが Google のディレクトリを読み取るうえで不可欠です。

理由:

理由 1: ユーザー プロビジョニング クライアント ID から権限が取り消された。

解決策:

管理コンソールで、[セキュリティ] > [詳細設定] の [API クライアントのアクセスを管理] を使用して、次のクライアント ID とスコープを追加します。

クライアント ID:
910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

スコープ:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

また、問題のアプリを削除してから、再度追加する方法もあります。

理由 2: 予期しないシステムエラー

解決策:

ほとんどの場合、このエラーは自動的に解消します。数時間経っても問題が解決しない場合は、前述の理由 1 で説明したように、クライアント ID とスコープを追加するか、アプリを削除して追加し直してください。

認証トークン エラー

エラーコード 説明と原因 解決策
17010

SCIM エンドポイントを呼び出すための認証情報が不足しています。

原因: 認証トークンが無効です。

[自動プロビジョニング] をクリックして [設定] を開き、[再認証] をクリックして、もう一度認証を試してください。
17013

サービス プロバイダからのアクセス トークンの取得中にエラーが発生しました。

原因: 認証トークンが無効です。

このエラーがしばらく経っても自動的に解決しない場合は、[自動プロビジョニング] をクリックして [設定] を開き、[再承認] をクリックして、もう一度承認を試してください。

アクセス トークン エラー

エラーコード 説明と原因 解決策
17002
17011

アクセス トークンを生成できませんでした。

原因: Google の一部の内部サービスが一時的に使用できなくなっています。

このエラーはしばらくすると自動的に解消します。
17009 更新トークンからアクセス トークンを生成する際にエラーが発生しました。 [自動プロビジョニング] をクリックして [設定] を開き、[再認証] をクリックして、もう一度認証を試してください。

一般的なエラー

エラーコード 説明と原因 解決策
1200x

内部エラー

このエラーはしばらくすると自動的に解消します。
25001 Google のバックエンドまたはサービスを一時的に使用できません。 自動プロビジョニングを再設定します。
25002

Google のバックエンドまたはサービスを一時的に使用できません。

原因: お客様のアプリがインストールされていません。

アプリケーションをインストールしてから、自動プロビジョニングを再度設定します。
25005 Google のバックエンドまたはサービスを一時的に使用できません。 このエラーはしばらくすると自動的に解消します。
25016 Google のバックエンドまたはサービスを一時的に使用できません。 自動プロビジョニングを再設定します。
50001 内部エラー このエラーはしばらくすると自動的に解消します。
50003 内部エラー このエラーはしばらくすると自動的に解消します。
50005 削除されたグループが、構成されたグループ フィルタに存在します。 プロビジョニングの対象の設定から削除されたグループを削除します。
50006 内部エラー このエラーはしばらくすると自動的に解消します。

リソースレベルのエラー

SAML アプリの設定ページの [自動プロビジョニング] セクションに [失敗] と表示されている場合は、[リストをダウンロード] をクリックします。ダウンロードしたファイルには、作成、削除、更新に失敗したアクションと、各失敗のエラーコードと説明が一覧表示されます。

これらのエラーは、ファイル内の指定されたリソースにのみ影響します。

エラーコード エラーの説明 解決策
45003

SCIM ベースのアプリケーションでリソースの更新、作成、削除リクエストが受け付けられませんでした。ダウンロードしたエラーファイルでエラーの詳細を確認してください。

考えられる原因:

  1. ライセンス上限の超過 - たとえば、SCIM ベースのアプリケーションで ユーザーを 5 人まで作成できるライセンスで、6 人分の自動プロビジョニングが有効になっています。
  2. 値が長すぎる - たとえば、メール ID などの値が長すぎるため、SCIM ベースのアプリケーションで受け付けられません。
  3. 少なくとも 1 つの利用資格(そのうちの 1 つはプロファイル ID)が必要です。
  4. 既に存在するユーザー名です。ユーザー名は、組織全体で一意の名前にする必要があります。
  5. リソース(ユーザー)がサービス プロバイダ(SP)側で見つかりませんでした。
  6. SCIM ユーザー ID の値が無効です。
エラーを修正して変更を保存した後、再試行します。
45004

サービス プロバイダと Google(ID プロバイダ)との間でエラーが発生しました。「内部エラー - 割り当ての上限を超えています」というエラー メッセージが表示されます。

考えられる原因:

  • サービス プロバイダに影響を与える不具合が発生した。
  • サービス プロバイダのサーバーがダウンしている。
サービス プロバイダにお問い合わせください。
45005 設定された SCIM エンドポイントにアクセスできません。管理コンソールで指定した SCIM エンドポイントを確認してください。 エラーを修正して変更を保存した後、再試行します。
45006

リソースの更新、作成、削除のリクエストが正常に作成されなかったか、SCIM ベースのアプリケーションで受け付けられませんでした。ダウンロードしたエラーファイルでエラーの詳細を確認してください。

考えられる原因:

  1. 値が長すぎる
  2. ライセンスの不足
  3. 無効なライセンス
  4. 利用資格の値が存在しない
エラーを修正して変更を保存した後、再試行します。
45016

必要項目を入力しなかったため、SCIM ベースのアプリケーションでリソースの更新、作成、削除リクエストが受け付けられませんでした。ダウンロードしたエラーファイルでエラーの詳細を確認してください。

エラーを修正して変更を保存した後、再試行します。