為 SAML 式應用程式設定自動佈建功能時,可能會看到下列錯誤:
請參閱下列說明,瞭解如何偵錯及解決這些錯誤。
設定時間失敗
授權碼錯誤
如果授權碼無法換取更新權杖,就會看到這則錯誤訊息。如果授權碼有誤,或是在授權後等候太久才點選「儲存變更」,就可能發生這種情況。重新授權並儲存變更應可解決這個問題。
| 錯誤訊息 | 解決方法 |
|---|---|
| 無法產生授權權杖。 | 重新嘗試授權並再次儲存變更。 |
過時頁面錯誤
如果使用者瀏覽器頁面未重新整理,且設定已在瀏覽器工作階段外變更 (透過其他瀏覽器視窗或由其他使用者變更),就會發生過時頁面錯誤。您可能會看到下列相關錯誤:
| 錯誤訊息 | 解決方法 |
|---|---|
| 您的網頁過舊。帳戶管理設定已存在。 | 重新整理網頁以覆寫現有的設定。 |
| 您的網頁過舊。帳戶管理設定不存在。 | 重新整理網頁以覆寫現有的設定。 |
| 您的網頁過舊。無法啟用尚未配置的帳戶管理設定。 | 重新整理網頁以覆寫現有的設定。 |
| 您的網頁過舊。無法刪除尚未配置的帳戶管理設定。 | 重新整理網頁以覆寫現有的設定。 |
暫時頁面錯誤
這些錯誤是暫時性的,重新整理頁面或稍後重試即可解決。
| 錯誤訊息 | 解析度 |
|---|---|
| 無法擷取佈建設定 | 重新整理網頁。 |
| 無法擷取帳戶管理前置設定 | 重新整理網頁。 |
| 無法擷取帳戶管理狀態 | 重新整理網頁。 |
| 佈建功能啟用失敗 | 重新嘗試啟用佈建功能。 |
| 刪除佈建設定時發生錯誤 | 重新嘗試刪除設定。 |
| 無法建立佈建設定 | 再次建立佈建設定並儲存變更。 |
| 無法更新帳戶管理設定 | 再次更新佈建設定並儲存變更。 |
| 無法擷取自訂屬性 | 重新嘗試儲存自訂屬性。 |
| 無法更新屬性對應 | 再次更新屬性對應。 |
| 無法更新自動帳戶管理的群組設定 | 再次更新群組設定。 |
| 無法更新取消帳戶管理設定 | 再次更新取消佈建設定。 |
| 已成功刪除設定,但無法撤銷 API 用戶端存取權 |
刪除設定時,系統會撤銷應用程式存取您在 Google 端資料的權限。 |
| 更新佈建設定時發生錯誤 | 重新整理網頁。 |
| 驗證失敗 | 設定中提供的驗證憑證 (例如不記名權杖) 有誤。請輸入正確的憑證。 |
| 提供的 SCIM 端點網址無效 | 提供的目標端點無效,請輸入正確的網址。 |
| 啟用佈建功能時發生錯誤 | 將「自動佈建」滑桿移至「啟用」。 |
| 刪除佈建設定時發生錯誤 |
|
| 無法從您的目標服務供應商擷取屬性 |
|
| 無法擷取您的目標資源架構 | 針對自動佈建設定過程中提供的端點網址進行驗證,並嘗試重新將 Cloud Directory 屬性對應到目標應用程式屬性。 |
自動佈建執行階段失敗
API 存取權、授權或設定問題,都可能導致自動佈建執行階段失敗。
Google 內部服務錯誤
驗證權杖錯誤
| 錯誤代碼 | 說明和原因 | 解決方法 |
|---|---|---|
| 17010 |
憑證不足,無法呼叫 SCIM 端點。 原因:驗證權杖已撤銷。 |
按一下「自動佈建」開啟「設定」,然後按一下「重新授權」,再次嘗試授權。 |
| 17013 |
從服務供應商擷取存取權杖時發生錯誤。 原因:驗證權杖已撤銷。 |
如果過一段時間後,這個錯誤仍未自動解決,請點選「自動佈建」開啟「設定」,然後點選「重新授權」,再次嘗試授權。 |
存取權杖錯誤
| 錯誤代碼 | 說明和原因 | 解析度 |
|---|---|---|
| 17002 17011 |
無法產生存取權杖。 原因:目前無法存取部分 Google 內部服務。 |
系統稍後應會自動解決這個錯誤。 |
| 17009 | 無法以更新權杖的方式產生存取權杖。 | 按一下「自動佈建」開啟「設定」,然後按一下「重新授權」,再次嘗試授權。 |
一般錯誤
| 錯誤代碼 | 說明和原因 | 解決方法 |
|---|---|---|
| 1200x |
內部錯誤 |
系統稍後應會自動解決這個錯誤。 |
| 25001 | Google 後端/服務暫時無法使用。 | 重新指定自動佈建設定。 |
| 25002 |
Google 後端/服務暫時無法使用。 原因:尚未為客戶安裝應用程式。 |
安裝應用程式,然後再次設定自動佈建功能。 |
| 25005 | Google 後端/服務暫時無法使用。 | 系統稍後應會自動解決這個錯誤。 |
| 25016 | Google 後端/服務暫時無法使用。 | 重新指定自動佈建設定。 |
| 50001 | 內部錯誤 | 系統稍後應會自動解決這個錯誤。 |
| 50003 | 內部錯誤 | 系統稍後應會自動解決這個錯誤。 |
| 50005 | 已刪除的群組出現在設定的群組篩選器中。 | 將已刪除的群組從帳戶管理範圍設定中移除。 |
| 50006 | 內部錯誤 | 系統稍後應會自動解決這個錯誤。 |
資源層級失敗
如果 SAML 應用程式設定頁面的「自動佈建」部分顯示「失敗」,請按一下「下載清單」。下載的檔案會列出建立、刪除或更新失敗的動作,以及每個失敗動作的錯誤代碼和說明。
這些錯誤只會影響檔案中指定的資源。
| 錯誤代碼 | 錯誤說明 | 解決方法 |
|---|---|---|
| 45003 |
SCIM 應用程式拒絕更新、建立或刪除資源的要求。請在下載的錯誤檔案中查看錯誤詳細資訊。 可能原因:
|
修正錯誤並在儲存變更後重試。 |
| 45004 |
服務供應商和 Google (識別資訊提供者) 間發生錯誤。顯示的錯誤文字訊息為「內部錯誤 - 超過配額」。
|
與服務供應商聯絡。 |
| 45005 | 無法連線至您設定的 SCIM 端點。請在管理控制台中勾選您提供的 SCIM 端點。 | 修正錯誤並在儲存變更後重試。 |
| 45006 |
無法正確建立資源更新、建立、刪除要求,或者 SCIM 應用程式不接受這些要求。請在下載的錯誤檔案中查看錯誤詳細資訊。 可能原因:
|
修正錯誤並在儲存變更後重試。 |
| 45016 |
必填欄位漏填,因此 SCIM 應用程式拒絕更新、建立或刪除資源的要求。請在下載的錯誤檔案中查看錯誤詳細資訊。 |
修正錯誤並在儲存變更後重試。 |