查看自动配置错误

为基于 SAML 的应用配置自动预配时,您可能会看到以下错误:

请阅读以下内容,了解如何调试和解决这些错误。

配置时间失败

授权代码错误

如果授权代码无法换取刷新令牌,您会看到此错误。如果您的授权代码不正确,或者您在授权和点击保存更改之间等待的时间过长,就可能会出现这种情况。 重新授权并保存更改可解决此问题。

错误消息 解决方法
无法生成授权令牌。 请重新尝试授权并再次保存更改。

过时页面错误

如果用户浏览器页面未刷新,并且配置已在此浏览器会话之外发生更改(无论是通过其他浏览器窗口还是由其他用户更改),则会发生过时页面错误。您可能会看到以下相关错误:

错误消息 解决方法
您的页面过旧。配置设置已存在。 请刷新以覆盖现有设置。
您的页面过旧。配置设置不存在。 请刷新以覆盖现有设置。
您的页面过旧。无法激活未配置的配置设置。 请刷新以覆盖现有设置。
您的页面过旧。无法删除未配置的配置设置。 请刷新以覆盖现有设置。

暂时性页面错误

这些错误是暂时性的,如果您刷新页面或在一段时间后重试相应操作,应该可以解决。

错误消息 分辨率
无法提取配置设置 请刷新页面。
无法提取配置预设值 请刷新页面。
无法提取配置状态 请刷新页面。
配置激活失败 请重新尝试激活配置。
删除配置设置时出错 请重新尝试删除配置。
无法创建配置设置 重新创建配置设置,然后保存所做更改。
无法更新配置设置 再次更新配置设置,然后保存更改。
无法提取自定义属性 请重新尝试保存自定义属性。
无法更新属性映射 再次更新属性映射。
无法更新自动配置的群组设置 再次更新群组设置。
无法更新取消配置设置 再次更新取消配置设置。
已成功删除配置,但无法撤消 API 客户端访问权限。

删除配置时,我们会撤消应用访问您 Google 方数据的权限。

如果因某种原因而失败,请通过安全性部分下的“管理 API 客户端访问权限”手动撤消访问权限。

如果您已删除配置并打算重新设置,则无需采取任何操作。

更新配置设置时出错 请刷新页面。
身份验证失败 配置中提供的身份验证凭据(例如不记名令牌)不正确。请输入正确的凭据。
提供的 SCIM 端点网址无效 提供的目标端点无效。请输入正确的网址。
启用配置时出错 将自动配置滑块移至有效。
删除配置设置时出错
  1. 点击自动配置以打开“设置”。
  2. 在删除配置下方,点击删除。
无法从目标服务提供商处提取属性
  1. 点击自动配置以打开“设置”。
  2. 在属性映射下方,点击修改。
  3. 根据需要修改服务提供商映射。
无法提取您的目标资源架构 请验证设置自动配置时提供的端点网址,然后重新尝试将云目录属性映射到目标应用属性。

自动配置运行时失败

自动预配运行时失败可能是由于 API 访问、授权或配置问题导致的。

Google 内部服务错误

错误代码 说明和解决方法
17003
17006
17008

说明:

无法通过 Google 内部服务进行身份验证。

原因:

已撤消此用户配置客户端 ID 的权限:

910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

解决方法:

请确保此 ID 有以下范围的权限:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

在管理控制台中,依次前往安全性 > 高级设置,然后使用“管理 API 客户端访问权限”来验证客户端 ID 是否具有这些范围,或者向该客户端 ID 添加这些范围。

17007

说明:

无法使用全网域授权向支持自动预配的应用授予访问权限。

无法向自动预配服务授予全网域委任权限。此授权至关重要,自动配置服务需要此授权才能读取 Google 目录。

原因:

原因 1:用户配置客户端 ID 的权限已被撤消。

解决方法:

在管理控制台中,依次选择安全 > 高级设置,然后使用“管理 API 客户端访问权限”添加以下客户端 ID 和范围:

客户端 ID:
910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

范围:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

另一种解决方法是删除相关应用,然后重新添加。

原因 2:意外的系统错误

解决方法:

在大多数情况下,此错误会自动解决。但是,如果此问题在数小时后仍然存在,那么请按上文“原因 1”中所述,添加相应客户端 ID 和范围,或删除并重新添加相应的应用。

身份验证令牌错误

错误代码 说明和原因 解决方法
17010

凭据不足,无法调用您的 SCIM 端点。

原因:身份验证令牌被撤消。

点击自动配置打开“设置”,然后点击重新授权,再次尝试重新授权。
17013

从您的服务提供商处提取访问令牌时出错。

原因:身份验证令牌被撤消。

如果此错误在一段时间后未自动解决,请尝试重新授权:点击自动配置打开“设置”,然后点击重新授权。

访问令牌错误

错误代码 说明和原因 分辨率
17002
17011

无法生成访问令牌。

原因:某些 Google 内部服务目前不可用。

此问题在一段时间后会自动解决。
17009 无法通过刷新令牌生成访问令牌。 点击自动配置打开“设置”,然后点击重新授权,再次尝试重新授权。

一般错误

错误代码 说明和原因 解决方法
1200x

内部错误

此问题在一段时间后会自动解决。
25001 Google 后端/服务暂时不可用。 请再次设置自动配置。
25002

Google 后端/服务暂时不可用。

原因:尚未为客户安装应用。

安装应用,然后重新设置自动配置。
25005 Google 后端/服务暂时不可用。 此问题在一段时间后会自动解决。
25016 Google 后端/服务暂时不可用。 请再次设置自动配置。
50001 内部错误 此问题在一段时间后会自动解决。
50003 内部错误 此问题在一段时间后会自动解决。
50005 已删除的群组存在于配置的群组过滤器中。 将已删除的群组从配置范围设置中移除。
50006 内部错误 此问题在一段时间后会自动解决。

资源层级失败

如果 SAML 应用设置页面上的“自动配置”部分显示失败,请点击下载列表。下载的文件会列出失败的创建、删除或更新操作,以及每次失败的错误代码和说明。

这些错误只会影响文件中的指定资源。

错误代码 错误说明 解决方法
45003

基于 SCIM 的应用不接受更新、创建和删除资源的请求。请在下载的错误文件中查看错误的详细信息。

可能的原因:

  1. 超出许可限制 - 您的许可只能在基于 SCIM 的应用上创建 5 位用户,但您为 6 位用户启用了自动配置。
  2. 值过长 - 您的值(如电子邮件 ID)过长,基于 SCIM 的应用不接受。
  3. 必须至少包含一项授权,其中一项必须是个人资料 ID。
  4. 用户名已存在。用户名在整个单位中必须是独一无二的。
  5. 服务提供商 (SP) 处找不到资源(用户)。
  6. SCIM 用户 ID 值无效。
请更正错误并在保存更改后重试。
45004

服务提供商和 Google(作为身份提供商)之间发生错误。错误消息为“内部错误 - 已超出配额”。

可能的原因:

  • 发生了影响服务提供商的服务中断。
  • 服务提供商的服务器断开。
请与服务提供商联系。
45005 您配置的 SCIM 端点无法访问。请检查您在管理控制台中提供的 SCIM 端点。 请更正错误并在保存更改后重试。
45006

无法正确建立更新、创建和删除资源的请求,或基于 SCIM 的应用不接受这些请求。请在下载的错误文件中查看错误的详细信息。

可能的原因:

  1. 值过长
  2. 许可数量不足
  3. 许可无效
  4. 使用权值不存在
请更正错误并在保存更改后重试。
45016

基于 SCIM 的应用拒绝更新、创建和删除资源的请求,因为您没有填写必填字段。请在下载的错误文件中查看错误的详细信息。

请更正错误并在保存更改后重试。