Quando configuri il provisioning automatico per le tue app basate su SAML, potresti visualizzare questi errori:
- Errori in fase di configurazione
- Errori di runtime del provisioning automatico
- Errori a livello di risorsa
Di seguito è indicato come eseguire il debug e risolvere questi errori.
Errori in fase di configurazione
Errore di codice di autorizzazione
Visualizzerai questo errore quando non è stato possibile scambiare il codice di autorizzazione con un token di aggiornamento. Questo può accadere se il codice di autorizzazione non è corretto o se attendi troppo tempo tra l'autorizzazione e il clic su Salva modifiche. L'errore dovrebbe risolversi riautorizzando e salvando le modifiche.
| Messaggio di errore | Risoluzione |
|---|---|
| Non è stato possibile generare il token di autorizzazione. | Prova a ripetere l'autorizzazione e salva di nuovo le modifiche. |
Errore di pagina non aggiornata
Gli errori di pagina non aggiornata si verificano quando la pagina del browser dell'utente non è stata aggiornata e la configurazione è cambiata al di fuori della sessione del browser (in un'altra finestra del browser o da un altro utente). Ecco gli errori associati che potresti visualizzare:
| Messaggio di errore | Risoluzione |
|---|---|
| La pagina non è aggiornata. Configurazione del provisioning già esistente. | Aggiorna la pagina per eseguire l'override della configurazione esistente. |
| La pagina non è aggiornata. Configurazione del provisioning non esistente. | Aggiorna la pagina per eseguire l'override della configurazione esistente. |
| La pagina non è aggiornata. Impossibile attivare una configurazione del provisioning non completata. | Aggiorna la pagina per eseguire l'override della configurazione esistente. |
| La pagina non è aggiornata. Impossibile eliminare una configurazione del provisioning non completata. | Aggiorna la pagina per eseguire l'override della configurazione esistente. |
Errore di pagina temporaneo
Questi errori sono temporanei e dovrebbero risolversi se aggiorni la pagina o riprovi l'azione dopo un certo periodo di tempo.
| Messaggio di errore | Risoluzione |
|---|---|
| Impossibile recuperare l'impostazione del provisioning | Aggiorna la pagina. |
| Impossibile recuperare la preconfigurazione del provisioning | Aggiorna la pagina. |
| Impossibile recuperare lo stato del provisioning | Aggiorna la pagina. |
| Attivazione del provisioning non riuscita | Riprova ad attivare il provisioning. |
| Errore durante l'eliminazione della configurazione del provisioning | Riprova a eliminare la configurazione. |
| Impossibile creare la configurazione del provisioning | Crea di nuovo la configurazione del provisioning e salva le modifiche. |
| Impossibile aggiornare la configurazione del provisioning | Aggiorna di nuovo la configurazione del provisioning e salva le modifiche. |
| Impossibile recuperare gli attributi personalizzati | Riprova a salvare gli attributi personalizzati. |
| Impossibile aggiornare la mappatura degli attributi | Aggiorna di nuovo la mappatura degli attributi. |
| Impossibile aggiornare le impostazioni di gruppo per il provisioning automatico | Aggiorna di nuovo le impostazioni del gruppo. |
| Impossibile aggiornare la configurazione del deprovisioning | Aggiorna di nuovo la configurazione del deprovisioning. |
| Configurazione eliminata. Non è stato possibile revocare l'accesso al client API. |
Quando elimini la configurazione, revochiamo le autorizzazioni che consentono all'applicazione di accedere ai tuoi dati su Google. |
| Errore durante l'aggiornamento della configurazione del provisioning | Aggiorna la pagina. |
| Autenticazione non riuscita | Le credenziali di autenticazione (ad es. token di autenticazione) fornite nella configurazione non sono corrette. Inserisci le credenziali corrette. |
| L'URL dell'endpoint SCIM fornito non è valido | L'endpoint di destinazione fornito non è valido. Inserisci l'URL corretto. |
| Errore durante l'attivazione del provisioning | Sposta il cursore Provisioning automatico su Attivo. |
| Errore durante l'eliminazione della configurazione del provisioning |
|
| Impossibile recuperare attributi dal provider Internet di destinazione |
|
| Impossibile recuperare schema risorsa target | Verifica l'URL dell'endpoint fornito durante la configurazione del provisioning automatico e riprova a mappare gli attributi di Cloud Directory agli attributi dell'applicazione di destinazione. |
Errori di runtime del provisioning automatico
Gli errori di runtime del provisioning automatico possono verificarsi a causa di problemi di accesso all'API, autorizzazione o configurazione.
Errori di servizi interni di Google
| Codice di errore | Descrizione e risoluzione |
|---|---|
| 17003 17006 17008 |
Descrizione: Impossibile eseguire l'autenticazione con i servizi interni di Google. Motivo: Le autorizzazioni sono state revocate da questo ID client di provisioning utenti: 910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com Risoluzione: Assicurati che l'ID disponga delle autorizzazioni necessarie per i seguenti ambiti: https://www.googleapis.com/auth/admin.directory.user.readonly, Nella Console di amministrazione, utilizza "Gestisci l'accesso client API" in Sicurezza > Impostazioni avanzate per verificare che l'ID client disponga di questi ambiti o per aggiungerli a questo ID client. |
| 17007 |
Descrizione: Impossibile concedere l'accesso alle app che supportano il provisioning automatico utilizzando la delega dell'autorità a livello di dominio. Impossibile concedere l'autorità di delega a livello di dominio al servizio di provisioning automatico. Questa impostazione è fondamentale per consentire al servizio di provisioning automatico di leggere la directory Google. Motivi: Motivo 1: le autorizzazioni sono state revocate dall'ID client di provisioning degli utenti. Risoluzioni: Nella Console di amministrazione, utilizza "Gestisci accesso client API" in Sicurezza > Impostazioni avanzate per aggiungere l'ID client e gli ambiti seguenti: ID client: Ambiti: https://www.googleapis.com/auth/admin.directory.user.readonly, Un'altra soluzione consiste nell'eliminare l'app in questione per poi aggiungerla di nuovo. Motivo 2: errori di sistema imprevisti Risoluzione: Nella maggior parte dei casi, questo errore si risolve automaticamente. Tuttavia, se il problema persiste dopo alcune ore, aggiungi l'ID client e gli ambiti oppure elimina e aggiungi di nuovo l'app, come illustrato per il motivo precedente. |
Errori del token di autenticazione
| Codice di errore | Descrizione e motivo | Risoluzione |
|---|---|---|
| 17010 |
Non ci sono credenziali sufficienti per effettuare chiamate all'endpoint SCIM. Causa: il token di autenticazione è stato revocato. |
Prova a eseguire nuovamente l'autorizzazione facendo clic su Provisioning automatico per aprire le impostazioni, quindi su Riautorizza. |
| 17013 |
Si è verificato un errore durante il recupero di un token di accesso dal tuo fornitore di servizi. Causa: il token di autenticazione è stato revocato. |
Se questo errore non si risolve automaticamente dopo un po' di tempo, prova a eseguire nuovamente l'autorizzazione facendo clic su Provisioning automatico per aprire le Impostazioni, quindi su Autorizza di nuovo. |
Errori del token di accesso
| Codice di errore | Descrizione e motivo | Risoluzione |
|---|---|---|
| 17002 17011 |
Impossibile generare un token di accesso. Motivo: al momento, alcuni servizi interni di Google non sono disponibili. |
Questo errore dovrebbe risolversi automaticamente in breve tempo. |
| 17009 | Generazione del token di accesso dal token di aggiornamento non riuscita. | Prova a eseguire nuovamente l'autorizzazione facendo clic su Provisioning automatico per aprire le impostazioni, quindi su Riautorizza. |
Errori generali
| Codice di errore | Descrizione e motivo | Risoluzione |
|---|---|---|
| 1200x |
Errore interno |
Questo errore dovrebbe risolversi automaticamente in breve tempo. |
| 25001 | Backend/servizio Google momentaneamente non disponibile. | Configura di nuovo il provisioning automatico. |
| 25002 |
Backend/servizio Google momentaneamente non disponibile. Causa: l'applicazione non è installata per il cliente. |
Installa l'applicazione e configura di nuovo il provisioning automatico. |
| 25005 | Backend/servizio Google momentaneamente non disponibile. | Questo errore dovrebbe risolversi automaticamente in breve tempo. |
| 25016 | Backend/servizio Google momentaneamente non disponibile. | Configura di nuovo il provisioning automatico. |
| 50001 | Errore interno | Questo errore dovrebbe risolversi automaticamente in breve tempo. |
| 50003 | Errore interno | Questo errore dovrebbe risolversi automaticamente in breve tempo. |
| 50005 | Un gruppo eliminato è presente nei filtri dei gruppi configurati. | Rimuovi il gruppo eliminato dalla configurazione dell'ambito di provisioning. |
| 50006 | Errore interno | Questo errore dovrebbe risolversi automaticamente in breve tempo. |
Errori a livello di risorsa
Se la sezione Provisioning automatico nella pagina delle impostazioni dell'app SAML mostra Errori, fai clic su Scarica elenco. Il file scaricato elenca le azioni di creazione, eliminazione o aggiornamento non riuscite e un codice di errore e una descrizione per ogni errore.
Questi errori riguardano solo le risorse specificate nel file.
| Codice di errore | Descrizione errore | Risoluzione |
|---|---|---|
| 45003 |
La richiesta di aggiornamento, creazione o eliminazione della risorsa non è stata accettata dalla tua applicazione basata su SCIM. Consulta i dettagli dell'errore nel file degli errori scaricato. Possibile causa:
|
Correggi l'errore e riprova dopo avere salvato le modifiche. |
| 45004 |
Si è verificato un errore tra il fornitore di servizi e Google come provider di identità. Il testo dell'errore è "Errore interno - Quota superata".
|
Contatta il fornitore di servizi |
| 45005 | L'endpoint SCIM che hai configurato non è raggiungibile. Controlla l'endpoint SCIM che hai indicato nella Console di amministrazione. | Correggi l'errore e riprova dopo avere salvato le modifiche. |
| 45006 |
La richiesta di aggiornamento, creazione o eliminazione della risorsa non è stata formulata correttamente o non è stata accettata dall'applicazione basata su SCIM. Consulta i dettagli dell'errore nel file degli errori scaricato. Possibile causa:
|
Correggi l'errore e riprova dopo avere salvato le modifiche. |
| 45016 |
La richiesta di aggiornamento, creazione o eliminazione della risorsa non è stata accettata dalla tua applicazione basata su SCIM perché non hai compilato un campo obbligatorio. Consulta i dettagli dell'errore nel file degli errori scaricato. |
Correggi l'errore e riprova dopo avere salvato le modifiche. |