Просмотреть ошибки автоматического предоставления ресурсов

При настройке автоматического предоставления ресурсов для приложений на основе SAML могут возникать следующие ошибки:

Ниже вы найдете информацию о том, как отлаживать и устранять эти ошибки.

Сбои во время настройки

Ошибка кода авторизации

Эта ошибка возникает, когда код авторизации не удается обменять на токен обновления. Это может произойти, если ваш код авторизации был неверным или если вы слишком долго ждете между авторизацией и нажатием кнопки «Сохранить изменения» . Повторная авторизация и сохранение изменений должны устранить эту ошибку.

Сообщение об ошибке Разрешение
Не удалось сгенерировать токен авторизации. Повторите авторизацию и сохраните изменения.

Ошибка устаревшей страницы

Ошибки "устаревшая страница" возникают, когда страница в браузере пользователя не обновлялась, а конфигурация изменялась вне текущей сессии браузера (либо из другого окна браузера, либо другим пользователем). Вот соответствующие ошибки, которые вы можете увидеть:

Сообщение об ошибке Разрешение
Ваша страница устарела. Настройка параметров доступна. Обновите страницу, чтобы отменить существующие настройки.
Ваша страница устарела. Настройки предоставления ресурсов отсутствуют. Обновите страницу, чтобы отменить существующие настройки.
Ваша страница устарела. Невозможно активировать ненастроенную систему подготовки ресурсов. Обновите страницу, чтобы отменить существующие настройки.
Ваша страница устарела. Невозможно удалить ненастроенные параметры предоставления ресурсов. Обновите страницу, чтобы отменить существующие настройки.

Временная ошибка страницы

Эти ошибки носят временный характер и должны исчезнуть, если вы обновите страницу или повторите действие через некоторое время.

Сообщение об ошибке Разрешение
Не удалось получить настройки подготовки. Обновите страницу.
Не удалось получить предварительную конфигурацию для предоставления ресурсов. Обновите страницу.
Не удалось получить статус подготовки. Обновите страницу.
Сбой активации системы. Повторите попытку активации предоставления ресурсов.
Ошибка при удалении настроек подготовки. Попробуйте удалить конфигурацию ещё раз.
Не удалось создать параметры подготовки. Создайте заново настройки подготовки и сохраните изменения.
Не удалось обновить настройки подготовки ресурсов. Снова обновите настройки подготовки и сохраните изменения.
Не удалось получить пользовательские атрибуты. Попробуйте сохранить свои пользовательские атрибуты.
Не удалось обновить сопоставление атрибутов. Обновите сопоставление атрибутов еще раз.
Не удалось обновить групповые настройки для автоматического предоставления ресурсов. Снова обновите настройки группы.
Не удалось обновить конфигурацию деактивации. Повторно обновите конфигурацию деактивации.
Удаление конфигурации прошло успешно, но не удалось отозвать доступ клиента API.

При удалении конфигурации мы отзываем разрешения, позволяющие вашему приложению получать доступ к данным, хранящимся в Google.

Если по какой-либо причине это не сработает, отзовите доступ вручную, перейдя в раздел « Управление доступом к API-клиенту » в подразделе «Безопасность» .

Если вы удалили конфигурацию и планируете настроить её заново, никаких действий предпринимать не нужно.

Ошибка при обновлении конфигурации подготовки ресурсов. Обновите страницу.
Аутентификация не удалась Указанные в конфигурации учетные данные для аутентификации (например, токен носителя) неверны. Введите правильные учетные данные.
Указанный URL-адрес конечной точки SCIM недействителен. Указанный целевой адрес недействителен. Введите правильный URL-адрес.
Ошибка при включении инициализации. Переместите ползунок автоматической настройки в положение «Активно» .
Ошибка при удалении настроек подготовки.
  1. Нажмите «Автоматическая настройка» , чтобы открыть «Параметры».
  2. В разделе «Удалить конфигурацию» нажмите «Удалить» .
Не удалось получить атрибуты от целевого поставщика услуг.
  1. Нажмите «Автоматическая настройка» , чтобы открыть «Параметры».
  2. В разделе «Сопоставление атрибутов» нажмите «Редактировать» .
  3. При необходимости отредактируйте сопоставление поставщиков услуг.
Не удалось получить схему целевого ресурса. Проверьте URL-адрес конечной точки, указанный во время автоматической настройки, и повторите попытку сопоставления атрибутов Cloud Directory с атрибутами целевого приложения.

Сбои автоматического выделения ресурсов во время выполнения

Сбои при автоматическом создании ресурсов во время выполнения могут возникать из-за проблем с доступом к API, авторизацией или конфигурацией.

ошибки внутренних служб Google

Код ошибки Описание и разрешение
17003
17006
17008

Описание:

Не удалось пройти аутентификацию во внутренних сервисах Google.

Причина:

У данного пользователя с указанным идентификатором клиента для предоставления доступа были отозваны права доступа:

910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

Разрешение:

Убедитесь, что у этого идентификатора есть права доступа к следующим областям:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

В консоли администратора используйте раздел « Управление доступом API-клиентов » в меню «Безопасность» > «Расширенные настройки» , чтобы убедиться, что идентификатор клиента имеет указанные области действия, или добавить эти области действия к данному идентификатору клиента.

17007

Описание:

Не удалось предоставить доступ приложениям, поддерживающим автоматическое выделение ресурсов, с использованием делегирования полномочий на уровне домена.

Не удалось предоставить службе автоматического предоставления прав делегирования в масштабе всего домена. Это критически важно для того, чтобы служба автоматического предоставления могла читать каталог Google.

Причины:

Причина 1: Были отозваны права доступа для идентификатора клиента, осуществляющего предоставление доступа.

Решения:

В консоли администратора в разделе «Безопасность» > «Расширенные настройки » используйте пункт « Управление доступом клиентов API », чтобы добавить следующие идентификаторы клиентов и области действия:

Идентификатор клиента:
910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

Области применения:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

В качестве альтернативного решения можно удалить проблемное приложение, а затем установить его заново.

Причина 2: Непредвиденные системные ошибки

Разрешение:

В большинстве случаев эта ошибка устраняется автоматически. Однако, если проблема сохраняется в течение нескольких часов, то либо добавьте идентификатор клиента и области действия, либо удалите и заново добавьте приложение, как указано в пункте 1 выше.

Ошибки токена аутентификации

Код ошибки Описание и причина Разрешение
17010

Недостаточно учетных данных для совершения звонков на вашу SCIM-терминал.

Причина: Токен авторизации отозван.

Попробуйте повторно авторизоваться, нажав «Автоматическая авторизация» , чтобы открыть «Настройки», а затем «Повторная авторизация» .
17013

Произошла ошибка при получении токена доступа от вашего поставщика услуг.

Причина: Токен авторизации отозван.

Если эта ошибка не исчезнет автоматически через некоторое время, попробуйте повторно авторизоваться, нажав «Автоматическая авторизация», чтобы открыть «Настройки», а затем «Повторная авторизация» .

ошибки токена доступа

Код ошибки Описание и причина Разрешение
17002
17011

Не удалось сгенерировать токен доступа.

Причина: В данный момент некоторые внутренние сервисы Google недоступны.

Эта ошибка должна устраниться автоматически через некоторое время.
17009 Генерация токена доступа из токена обновления завершилась неудачей. Попробуйте повторно авторизоваться, нажав «Автоматическая авторизация» , чтобы открыть «Настройки», а затем «Повторная авторизация» .

Общие ошибки

Код ошибки Описание и причина Разрешение
1200x

Внутренняя ошибка

Эта ошибка должна устраниться автоматически через некоторое время.
25001 Сервис Google временно недоступен. Настройте автоматическую инициализацию заново.
25002

Сервис Google временно недоступен.

Причина: Приложение не установлено для клиента.

Установите приложение, а затем снова настройте автоматическую инициализацию.
25005 Сервис Google временно недоступен. Эта ошибка должна устраниться автоматически через некоторое время.
25016 Сервис Google временно недоступен. Настройте автоматическую инициализацию заново.
50001 Внутренняя ошибка Эта ошибка должна устраниться автоматически через некоторое время.
50003 Внутренняя ошибка Эта ошибка должна устраниться автоматически через некоторое время.
50005 В настроенных фильтрах групп присутствует удаленная группа. Удалите удаленную группу из конфигурации области предоставления ресурсов.
50006 Внутренняя ошибка Эта ошибка должна устраниться автоматически через некоторое время.

Сбои на уровне ресурсов

Если в разделе «Автоматическая настройка» на странице настроек приложения SAML отображается «Сбои» , нажмите «Загрузить список». В загруженном файле будет указан список неудачных действий по созданию, удалению или обновлению, а также код ошибки и описание для каждого сбоя.

Эти ошибки затрагивают только указанные ресурсы в файле.

Код ошибки Описание ошибки Разрешение
45003

Запрос на обновление, создание или удаление ресурса не был принят вашим приложением на базе SCIM. Подробности ошибки см. в загруженном файле с ошибками.

Возможные причины:

  1. Превышен лимит лицензий — у вас есть лицензии только на создание 5 пользователей в вашем приложении на базе SCIM, а автоматическое выделение ресурсов включено для 6 пользователей.
  2. Слишком длинное значение — ваше значение, например, адрес электронной почты, слишком длинное и неприемлемо для вашего приложения на основе SCIM.
  3. Необходимо иметь как минимум одно право доступа, одно из которых должно быть идентификатором профиля.
  4. Имя пользователя уже существует. Оно должно быть уникальным во всей организации.
  5. Ресурс (Пользователь) не найден на стороне поставщика услуг (SP).
  6. Недопустимое значение идентификатора пользователя SCIM.
Исправьте ошибку и повторите попытку после сохранения изменений.
45004

Произошла ошибка между поставщиком услуг и Google, выступающим в качестве поставщика идентификационных данных. Текст ошибки: «Внутренняя ошибка — превышена квота».

Возможные причины:

  • Сбой, затрагивающий поставщика услуг.
  • Сервер поставщика услуг недоступен.
Свяжитесь с поставщиком услуг.
45005 Настроенная вами конечная точка SCIM недоступна. Проверьте конечную точку SCIM, указанную вами в консоли администратора. Исправьте ошибку и повторите попытку после сохранения изменений.
45006

Запрос на обновление, создание или удаление ресурса был сформирован некорректно или не был принят приложением на основе SCIM. Подробности ошибки см. в загруженном файле с ошибками.

Возможные причины:

  1. Значение слишком велико
  2. Недостаточно лицензий
  3. Недействительная лицензия
  4. Право на получение дохода отсутствует.
Исправьте ошибку и повторите попытку после сохранения изменений.
45016

Запрос на обновление, создание или удаление ресурса не был принят вашим приложением на базе SCIM, поскольку вы не заполнили обязательное поле. Подробности ошибки см. в загруженном файле с ошибками.

Исправьте ошибку и повторите попытку после сохранения изменений.