Versioni supportate per questa funzionalità: Frontline Standard e Frontline Plus; Business Plus; Enterprise Standard ed Enterprise Plus; Education Fundamentals, Education Standard ed Education Plus; Enterprise Essentials Plus. Confronta la tua versione
Il servizio LDAP sicuro restituisce codici di errore quando si verifica un problema nell'elaborazione delle richieste LDAP. Questi errori si verificano durante il processo di connessione di un client LDAP e di eventuali query LDAP successive alla connessione. Il modo in cui i client LDAP espongono i codici di errore agli utenti finali e se lo fanno dipende dal client LDAP specifico. I codici di errore descritti in questo articolo vengono visualizzati anche nei log di controllo.
PROTOCOL_ERROR (2) (Errore di protocollo, 2)
- Errore restituito quando una richiesta specifica una versione LDAP non supportata. Il servizio LDAP sicuro supporta LDAP versione 3.
- Errore restituito quando una richiesta specifica un'azione non supportata. Google supporta Abandon, Bind, Extended (per StartTLS), Search e Unbind. Le azioni non supportate sono: Aggiungi, Confronta, Elimina, Modifica e ModificaDn.
- Errore restituito quando una richiesta Extended (Estesa) specifica un OID non supportato. Google supporta solo l'azione Estesa per StartTLS (Oid 1.3.6.1.4.1.1466.20037) su una connessione precedentemente non protetta.
AUTH_METHOD_NOT_SUPPORTED (7)
- Restituito quando una richiesta Bind specifica un metodo di autenticazione non supportato. Google supporta i metodi SIMPLE, SASL PLAIN e SASL EXTERNAL.
ADMIN_LIMIT_EXCEEDED (11) (Limite amministrativo superato, 11)
- Il servizio LDAP sicuro ha quote per le richieste di binding e di ricerca. Il superamento di una delle due quote attiverà questo messaggio di errore.
- La quota di binding è di 4 query al secondo (QPS) per cliente, condivise su tutti i domini di proprietà del cliente.
- Se viene visualizzato l'errore ADMIN_LIMIT_EXCEEDED, indica quale operazione (ricerca o associazione) sta superando la quota, quindi prova a ridurre la frequenza dell'operazione. Ad esempio, l'autenticazione Wi-Fi tramite RADIUS può generare un numero elevato di operazioni di binding, superando la quota.
CONFIDENTIALITY_REQUIRED (13) (Riservatezza obbligatoria, 13)
- Errore restituito quando una richiesta SASL Bind viene eseguita su una connessione non sicura.
- Restituito quando una richiesta di ricerca esegue query su elementi diversi dagli attributi del server e viene emessa tramite una connessione non protetta
NO_SUCH_OBJECT (32) (Oggetto non trovato, 32)
- Restituito quando si cerca qualcosa che non esiste (ad esempio, un utente, un gruppo o un'unità organizzativa sconosciuti)
- Restituito quando si cerca un ID utente che non è presente nella directory
INVALID_DN_SYNTAX (34) (Sintassi DN non valida [34])
- Restituito quando un nome distinto è malformato e non analizzabile da JNDI. Vedi javax.naming.ldap.LdapName
- Restituito quando un nome distinto include un attributo con un valore che non è una stringa. Sono supportati solo i valori String. Vedi javax.naming.directory.Attribute
INAPPROPRIATE_AUTHENTICATION (48) (Autenticazione inadeguata, 48)
- Restituito quando una richiesta di associazione specifica un certificato client non valido, scaduto o danneggiato
- Restituito quando una richiesta di binding SASL PLAIN specifica credenziali non valide o non specifica credenziali
INSUFFICIENT_ACCESS_RIGHTS (50)
- Errore restituito quando il servizio LDAP sicuro è disattivato per il client LDAP.
- Errore restituito quando il cliente non dispone della licenza per utilizzare il servizio LDAP sicuro.
- Restituito quando la richiesta di associazione specifica un utente che non dispone della licenza per utilizzare LDAP sicuro
- Errore restituito quando una richiesta Bind specifica un utente disattivato.
- Restituito quando una richiesta di associazione successiva (riassociazione) specifica un utente che non appartiene a un'unità organizzativa abilitata per l'autenticazione nella configurazione LDAP sicuro
- Restituito quando una richiesta SIMPLE Bind non specifica credenziali (non autenticata)
UNWILLING_TO_PERFORM (53) (Non eseguibile, 53)
- Restituito quando una richiesta SIMPLE Bind non specifica credenziali (non autenticata)
ALTRO (80)
- Questo errore viene restituito a causa di un risultato imprevisto dovuto a un bug nel codice. Se ricevi questo errore, contatta l'assistenza Google Workspace o l'assistenza premium Cloud Identity.
CANCELLATO (118)
- Errore restituito quando una richiesta Abandon interrompe un'operazione LDAP esistente.